2019-05-25 00:38 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002203NetSurfRISC OS-specificpublic2016-02-16 14:36
ReporterHarriet Bazley 
Assigned ToDaniel Silverstone 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformARMOSRISC OSOS Version5.19
Product Version3.2 
Target Version3.4Fixed in Version3.4 
Summary0002203: Crash on visiting Livejournal inbox
DescriptionNetsurf crashes with a segmentation fault when rendering the page http://www.livejournal.com/inbox, whether by selecting from the hotlist, double-clicking from a StrongED file or typing the URL directly into the application.
Additional InformationIyonix, RISC OS 5.20
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2122
URL of problem pagehttp://www.livejournal.com/inbox
Attached Files

-Relationships
has duplicate 0002269closedDaniel Silverstone Segfault while idle 
has duplicate 0002114closedVincent Sanders Spontaneous crash 
has duplicate 0002321closed Another crash at bbc news website 
+Relationships

-Notes
Harriet Bazley

~0000500

Harriet Bazley (reporter)

Last edited: 2014-09-23 21:58

View 2 revisions

It appears to be a problem with this specific user/journal, as I have been able to view other Livejournal blogs (for example capriuni.livejournal.com) without any crash, but attempting to log in (login/zip) or just to view that journal without logging in (visit/zip) both cause crashes.

Logging in via the mobile site is fine (and enables me to view 'friends-only' journals in the standard desktop view), but results in a crash if I subsequently attempt to view the inbox in standard view...

Harriet Bazley

~0000501

Harriet Bazley (reporter)

Tried using Netsurf v1967, which definitely used to work: this seemed OK for a while then crashed (1967/zip). It looks as if something has changed about the site within the last week.
Harriet Bazley

~0000504

Harriet Bazley (reporter)

Tried again with v2127 on Iyonix: again site seemed fine for a while, then crashed.
However, I have had no trouble (touch wood) in accessing the same pages using Netsurf v2117 on this ARMini (RISC OS 5.21), so the issue would appear to be possibly hardware/OS specific.
Harriet Bazley

~0000541

Harriet Bazley (reporter)

Still crashing regularly when attempting to edit/add entries to this journal. This [snipped - last 10Kb] log is from Netsurf v2387 on ARMini, so it's not hardware specific: the error is always a segmentation fault, and the stack backtrace has been the same in every log I've looked at recently:
free_unlocked()
__free()
form_free_control()
form_free()
^html_destroy()
content_destroy()
^hlcache_clean()
schedule_run()
^riscos_poll()
main()
Harriet Bazley

~0000595

Harriet Bazley (reporter)

Still crashing with relentless reproducibility on both Iyonix and ARMini after editing/posting journal entries. Here Netsurf v2585 has just crashed on the ARMini (RISC OS 5.21) after doing nothing but logging in and performing a single edit.
Vincent Sanders

~0000806

Vincent Sanders (administrator)

Is this still occurring with 3.3? I have added some form debugging code to teh latest CI build so can you try with that?
Harriet Bazley

~0000807

Harriet Bazley (reporter)

Unfortunately (see issue ID 0002296) it is currently impossible to log into LiveJournal and edit an article at all in order to provoke the bug reproducibly for test purposes :-(
Harriet Bazley

~0000812

Harriet Bazley (reporter)

Here's an example of this free_unlocked() crash that I managed to get with the latest Netsurf (Dev 2689) while posting a new article -- as opposed to editing one.
Note that the title of this bug is now obsolete: the problem appears to have nothing to do with the actual Livejournal inbox but to have migrated(?) to other parts of the site...

Iyonix Aria RISC OS 5.20
Harriet Bazley

~0000831

Harriet Bazley (reporter)

And another one (dev 2721): the problem appears to be with form_free_control.
Daniel Silverstone

~0000834

Daniel Silverstone (administrator)

I have committed a fix for form control destruction, could the OP please re-test with a recent CI #2736 or later
Harriet Bazley

~0000840

Harriet Bazley (reporter)

Tested with CI 2744 - I didn't get it to crash, but unfortunately most of the features which reliably provoked this site to do so are no longer accessible with Netsurf as of the last month, due to changes to the back end resulting in log-in/cookie issues.
I'll keep an eye on it, but in the absence of a fix for the latter I'm seeing a lot less of Livejournal anyway :-(
Harriet Bazley

~0000851

Harriet Bazley (reporter)

I think - touch wood - this is now fixed. I haven't seen any more of these crashes since this change.
Vincent Sanders

~0001271

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2014-09-23 20:48 Harriet Bazley New Issue
2014-09-23 20:48 Harriet Bazley File Added: Log.zip
2014-09-23 21:52 Harriet Bazley File Added: Login.zip
2014-09-23 21:58 Harriet Bazley Note Added: 0000500
2014-09-23 21:58 Harriet Bazley Note Edited: 0000500 View Revisions
2014-09-23 22:08 Harriet Bazley File Added: visit.zip
2014-09-23 22:09 Harriet Bazley Note Added: 0000501
2014-09-23 22:09 Harriet Bazley File Added: 1967.zip
2014-09-24 08:47 Vincent Sanders Status new => acknowledged
2014-09-30 02:07 Harriet Bazley Note Added: 0000504
2014-11-29 00:45 Harriet Bazley File Added: logsnip.zip
2014-11-29 00:48 Harriet Bazley Note Added: 0000541
2015-02-02 09:36 Harriet Bazley File Added: 2585.zip
2015-02-02 09:38 Harriet Bazley Note Added: 0000595
2015-02-04 09:02 Vincent Sanders Relationship added has duplicate 0002269
2015-03-27 17:10 Vincent Sanders Note Added: 0000806
2015-03-27 17:10 Vincent Sanders Status acknowledged => feedback
2015-03-28 16:57 Harriet Bazley Note Added: 0000807
2015-03-28 16:57 Harriet Bazley Status feedback => new
2015-03-30 15:15 Vincent Sanders Status new => acknowledged
2015-03-31 23:36 Harriet Bazley File Added: Mar31Log.zip
2015-03-31 23:39 Harriet Bazley Note Added: 0000812
2015-04-15 12:18 Harriet Bazley Note Added: 0000831
2015-04-15 12:19 Harriet Bazley File Added: Log2721
2015-04-22 21:58 Daniel Silverstone Assigned To => Daniel Silverstone
2015-04-22 21:58 Daniel Silverstone Status acknowledged => assigned
2015-04-22 21:59 Daniel Silverstone Note Added: 0000834
2015-04-22 22:20 Vincent Sanders Status assigned => feedback
2015-04-22 22:20 Vincent Sanders Target Version => 3.4
2015-04-26 22:34 Harriet Bazley Note Added: 0000840
2015-04-26 22:34 Harriet Bazley Status feedback => assigned
2015-05-12 09:41 Vincent Sanders Relationship added has duplicate 0002114
2015-05-14 14:19 Harriet Bazley Note Added: 0000851
2015-05-14 17:15 Vincent Sanders Status assigned => resolved
2015-05-14 17:15 Vincent Sanders Fixed in Version => 3.4
2015-06-01 01:20 Vincent Sanders Relationship added has duplicate 0002321
2015-10-31 21:45 Vincent Sanders Resolution open => fixed
2016-02-16 14:36 Vincent Sanders Note Added: 0001271
2016-02-16 14:36 Vincent Sanders Status resolved => closed
+Issue History