2019-09-21 10:32 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002269NetSurfABENDpublic2016-02-16 15:28
ReporterRichard Porter 
Assigned ToDaniel Silverstone 
SeveritycrashReproducibilityN/A 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.14
Product Version3.3 
Target Version3.4Fixed in Version3.4 
Summary0002269: Segfault while idle
DescriptionNetSurf spontaneously crashed with a segmentation fault while idle. No windows were open.
Steps To ReproduceNone. This was totally random.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2560
URL of problem pagenone
Attached Files

-Relationships
duplicate of 0002203closedDaniel Silverstone Crash on visiting Livejournal inbox 
+Relationships

-Notes
Vincent Sanders

~0000599

Vincent Sanders (administrator)

  ( 6b1be8) pc: 4a4b68 lr: 4a5bdc sp: 6b1bec free_unlocked()
  ( 6b1c00) pc: 4a5bb4 lr: 8c398 sp: 6b1c04 __free()
  ( 6b1c1c) pc: 8c37c lr: 8c48c sp: 6b1c20 form_free_control()
  ( 6b1c34) pc: 8c46c lr: 8e1f8 sp: 6b1c38 form_free()
  ( 6b1c54) pc: 8e1c8 lr: 33a84 sp: 6b1c58 html_destroy()
  ( 6b1c68) pc: 33a40 lr: 3eb68 sp: 6b1c6c content_destroy()
  ( 6b1c84) pc: 3eae8 lr: cfdcc sp: 6b1c88 hlcache_clean()
  ( 6b1ca4) pc: cfd84 lr: 9dd0 sp: 6b1ca8 schedule_run()
  ( 6b1fe8) pc: 9548 lr: 4aafa4 sp: 6b1fec main()
Daniel Silverstone

~0000835

Daniel Silverstone (administrator)

A fix was committed recently (CI #2736) - please verify if you can still reproduce.
Richard Porter

~0000836

Richard Porter (reporter)

Sorry, as this was a totally random crash while NetSurf was apparently idle I am unable to reproduce it at will.
Vincent Sanders

~0000849

Vincent Sanders (administrator)

closing as Daniel fix does seem to have worked and content destruction is now much less crashy.
Vincent Sanders

~0001313

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-02-03 23:15 Richard Porter New Issue
2015-02-03 23:15 Richard Porter File Added: nslog310.zip
2015-02-04 09:01 Vincent Sanders Note Added: 0000599
2015-02-04 09:01 Vincent Sanders Status new => acknowledged
2015-02-04 09:01 Vincent Sanders Category General => ABEND
2015-02-04 09:01 Vincent Sanders Product Version => 3.3
2015-02-04 09:02 Vincent Sanders Relationship added duplicate of 0002203
2015-04-22 22:21 Daniel Silverstone Assigned To => Daniel Silverstone
2015-04-22 22:21 Daniel Silverstone Status acknowledged => assigned
2015-04-22 22:21 Daniel Silverstone Note Added: 0000835
2015-04-22 23:02 Richard Porter Note Added: 0000836
2015-05-12 09:51 Vincent Sanders Note Added: 0000849
2015-05-12 09:51 Vincent Sanders Status assigned => resolved
2015-05-12 09:51 Vincent Sanders Resolution open => fixed
2015-05-12 09:51 Vincent Sanders Fixed in Version => 3.4
2015-05-12 09:51 Vincent Sanders Target Version => 3.4
2016-02-16 15:28 Vincent Sanders Note Added: 0001313
2016-02-16 15:28 Vincent Sanders Status resolved => closed
+Issue History