2019-01-16 17:19 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002114NetSurfABENDpublic2016-02-16 15:28
ReporterRichard Porter 
Assigned ToVincent Sanders 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.14
Product Version3.1 
Target Version3.4Fixed in Version3.4 
Summary0002114: Spontaneous crash
DescriptionNS crashed with a segmentation fault when not being used. I was processing some images with !DPlngScan at the time. NS also crashed when I was trying to report the crash - report to follow.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #1814
URL of problem pagenone
Attached Files

-Relationships
duplicate of 0002203closedDaniel Silverstone Crash on visiting Livejournal inbox 
duplicate of 0002178closedVincent Sanders Segmentation Fault 
+Relationships

-Notes
Richard Porter

~0000314

Richard Porter (reporter)

This is repeatable. NS crashed again when I opened the same image file in !DPlngScan. It also crashed again when I tried to report the crash.
Richard Porter

~0000315

Richard Porter (reporter)

FWIW I've uploaded the offending jpeg file.
Vincent Sanders

~0000848

Vincent Sanders (administrator)

This is two bugs, the first crash is related to the forms issues on content destruction which is being handled in bug 2203

The second was the png handler failing to cope with running out of memory and is fixed in bug 2178
Vincent Sanders

~0001314

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2014-04-29 20:37 Richard Porter New Issue
2014-04-29 20:37 Richard Porter File Added: nslog292.zip
2014-04-29 20:48 Richard Porter Note Added: 0000314
2014-04-29 20:49 Richard Porter File Added: nslog294.zip
2014-04-29 20:49 Richard Porter File Added: 0x5fa2c338
2014-04-29 20:50 Richard Porter Note Added: 0000315
2014-04-30 12:43 Vincent Sanders Status new => acknowledged
2014-04-30 12:43 Vincent Sanders Category RISC OS-specific => ABEND
2014-04-30 12:43 Vincent Sanders Product Version => 3.1
2015-05-12 08:41 Vincent Sanders Relationship added duplicate of 0002203
2015-05-12 08:41 Vincent Sanders Relationship added duplicate of 0002178
2015-05-12 08:44 Vincent Sanders Note Added: 0000848
2015-05-12 08:44 Vincent Sanders Assigned To => Vincent Sanders
2015-05-12 08:44 Vincent Sanders Reproducibility have not tried => sometimes
2015-05-12 08:44 Vincent Sanders Status acknowledged => resolved
2015-05-12 08:44 Vincent Sanders Resolution open => fixed
2015-05-12 08:44 Vincent Sanders Fixed in Version => 3.4
2015-05-12 08:44 Vincent Sanders Target Version => 3.4
2016-02-16 15:28 Vincent Sanders Note Added: 0001314
2016-02-16 15:28 Vincent Sanders Status resolved => closed
+Issue History