2019-05-26 22:45 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002178NetSurfRISC OS-specificpublic2016-02-16 15:28
ReporterRichard Porter 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.14
Product Version3.2 
Target VersionFixed in Version3.4 
Summary0002178: Segmentation Fault
DescriptionNS crashes whilst scrolling through the clubs pages on the IMM 2014 web site.
Steps To ReproduceGo to the problem page and scroll down to the bottom. If NS hasn't yet crashed go to the next page of clubs. Repeat if necessary. It will crash before you get to the end.
Additional InformationTwo logs attached.
TagsNo tags attached.
Fixed in CI build #2775
Reported in CI build #2036
URL of problem pagehttp://www.imm2014.co.uk/clubs-attending-imm-2014
Attached Files

-Relationships
has duplicate 0002114closedVincent Sanders Spontaneous crash 
+Relationships

-Notes
Vincent Sanders

~0000424

Vincent Sanders (administrator)

20210.630000) image/png.c nspng_warning 80: iCCP: Not recognizing known sRGB profile that has been edited
(20212.730000) image/jpeg.c nsjpeg_error_exit 160: Unsupported color conversion request
(20214.470000) image/jpeg.c nsjpeg_error_exit 160: Unsupported color conversion request
(20215.770000) image/png.c nspng_warning 80: iCCP: Not recognizing known sRGB profile that has been edited


looks like a corrupt image is blowing up the png handler
Daniel Silverstone

~0000436

Daniel Silverstone (administrator)

This page appears to be very image heavy with a lot of jpg and png images on there, some of which we are unable to decode for some reason related to colour conversion.

Unfortunately we cannot reproduce this crash on Debian/wheezy which might be libpng version related. Someone will need to set up a build environment with a different libpng to test this further.
David Pitt

~0000789

David Pitt (reporter)

This site no longer exists.

http://www.imm2014.co.uk/
 
Web Site Not Found

Sorry, we could not find any content for this web address. Please check the URL.

If you are an Acquia Cloud customer and expect to see your site at this address, you'll need to add this domain name to your site via the Acquia Network management console.
Vincent Sanders

~0000847

Vincent Sanders (administrator)

The PNG image handler was failing to cope with failiure to allocate bitmap buffers. Fixed now
Vincent Sanders

~0001315

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2014-07-29 14:27 Richard Porter New Issue
2014-07-29 14:27 Richard Porter File Added: nslog302.zip
2014-07-29 16:25 Vincent Sanders Note Added: 0000424
2014-07-29 16:25 Vincent Sanders Status new => acknowledged
2014-07-29 16:25 Vincent Sanders Category General => RISC OS-specific
2014-07-29 16:25 Vincent Sanders Product Version => 3.2
2014-08-03 15:06 Daniel Silverstone Note Added: 0000436
2015-03-18 07:23 David Pitt Note Added: 0000789
2015-05-12 09:32 Vincent Sanders Fixed in CI build # => 2775
2015-05-12 09:32 Vincent Sanders Note Added: 0000847
2015-05-12 09:32 Vincent Sanders Assigned To => Vincent Sanders
2015-05-12 09:32 Vincent Sanders Status acknowledged => resolved
2015-05-12 09:32 Vincent Sanders Resolution open => fixed
2015-05-12 09:32 Vincent Sanders Fixed in Version => 3.4
2015-05-12 09:41 Vincent Sanders Relationship added has duplicate 0002114
2016-02-16 15:28 Vincent Sanders Note Added: 0001315
2016-02-16 15:28 Vincent Sanders Status resolved => closed
+Issue History