2019-05-25 00:40 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000382NetSurfJavascriptpublic2015-03-10 23:38
ReporterDave Higton 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformIyonixOSRISC OSOS Version5.18
Product Version 
Target Version3.3Fixed in Version3.3 
Summary0000382: Crash on closing a window while page is loading
DescriptionRepeat of bug 3608526, which has been closed although the problem still occurs and never stopped occurring.

If you set NS loading a page, and close the window while the page is loading, NS crashes. The attached crash log is from doing that with a page from the BBC's new web site with NS CI 0001249 json and enabled but it's done it with hundreds of versions for a while now (the original report was with CI 0000985 and that was far from the first).

Fully repeatable, not site specific, AFAICS.

Iyonix, RO 5.18, 512 MiB.
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3614357 on Tue Dec 10 17:34:12 2013
TagsNo tags attached.
Fixed in CI build #2623
Reported in CI build #
URL of problem page
Attached Files

-Relationships
duplicate of 0002279closedVincent Sanders Spontaneous crash. 
+Relationships

-Notes
Vincent Sanders

~0000013

Vincent Sanders (administrator)

This appears to be specific to RISC OS

From the log stacktrace:
  ( 652c28) pc: 77b4c lr: 9385c sp: 652c2c js_exec()
  ( 652c5c) pc: 93654 lr: 3aa74 sp: 652c60 ^convert_script_sync_cb()
  ( 652d30) pc: 3a754 lr: 3ad74 sp: 652d34 ^hlcache_migrate_ctx()
  ( 652dd8) pc: 3ab50 lr: 3bd8c sp: 652ddc ^hlcache_llcache_callback()
  ( 652e0c) pc: 3bc10 lr: 3c65c sp: 652e10 ^llcache_object_notify_users()
  ( 652e24) pc: 3c634 lr: 3ae20 sp: 652e28 llcache_poll()
  ( 652e34) pc: 3ae14 lr: 5ded4 sp: 652e38 hlcache_poll()
  ( 652e4c) pc: 5deac lr: b8f64 sp: 652e50 netsurf_main_loop()
  ( 652fe8) pc: b89f4 lr: 4bdd40 sp: 652fec main()

which seems to indicate that closing the window fails to abort the fetch correctly and when the script callback executes the script it goes bang for obvious reasons.

should convert_script_sync_cb() in handling CONTENT_MSG_DONE skip the execution if the parent content has been aborted? certainly I am unable to reproduce this on gtk or framebuffer frontends.
Michael Drake

~0000148

Michael Drake (administrator)

With nsgtk you need to be quick.

Open click BBC News link, and immediately Shift+Ctrl+W (close window).

Segfault.
Vincent Sanders

~0000633

Vincent Sanders (administrator)

I think I have finally fixed this issue alongside two others with the same root cause. can I ask you to please confirm with CI build 2623 ?
Michael Drake

~0000635

Michael Drake (administrator)

I can't reproduce the segfault with the latest version.

It does seem to load a lot of lwc strings on exit though.
Dave Higton

~0000636

Dave Higton (developer)

I have given build 2625 a good thrash and have been unable to break it, so it looks like it's fixed. Thank you!
Vincent Sanders

~0000735

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-10 17:41 Vincent Sanders Description Updated View Revisions
2013-12-11 16:27 Vincent Sanders Note Added: 0000013
2013-12-11 16:27 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-11 16:27 Vincent Sanders Severity minor => major
2013-12-11 16:27 Vincent Sanders Reproducibility have not tried => sometimes
2013-12-11 16:27 Vincent Sanders Status assigned => confirmed
2013-12-11 16:27 Vincent Sanders Resolution no change required => reopened
2013-12-11 16:27 Vincent Sanders Category General => RISC OS-specific
2013-12-11 16:27 Vincent Sanders OS => RISC OS
2013-12-11 16:27 Vincent Sanders OS Version => 5.18
2013-12-11 16:27 Vincent Sanders Platform => Iyonix
2013-12-11 16:27 Vincent Sanders Description Updated View Revisions
2013-12-11 16:27 Vincent Sanders Additional Information Updated View Revisions
2014-01-03 00:53 Vincent Sanders Assigned To => Steve Fryatt
2014-01-03 00:53 Vincent Sanders Status confirmed => assigned
2014-01-03 00:54 Vincent Sanders Status assigned => acknowledged
2014-01-03 17:27 Michael Drake Assigned To Steve Fryatt => Michael Drake
2014-01-03 17:27 Michael Drake Status acknowledged => assigned
2014-01-03 17:30 Michael Drake Note Added: 0000148
2014-01-03 17:30 Michael Drake Assigned To Michael Drake => Vincent Sanders
2014-01-03 17:30 Michael Drake Reproducibility sometimes => always
2014-01-03 17:30 Michael Drake Status assigned => confirmed
2014-01-03 17:30 Michael Drake Category RISC OS-specific => Javascript
2014-02-07 16:12 Michael Drake Severity major => crash
2014-02-07 16:12 Michael Drake Description Updated View Revisions
2014-02-07 16:12 Michael Drake Additional Information Updated View Revisions
2015-03-07 18:43 Vincent Sanders Relationship added duplicate of 0002279
2015-03-07 18:52 Vincent Sanders Fixed in CI build # => 2623
2015-03-07 18:52 Vincent Sanders Note Added: 0000633
2015-03-07 18:52 Vincent Sanders Status confirmed => feedback
2015-03-07 18:52 Vincent Sanders Resolution reopened => fixed
2015-03-07 18:52 Vincent Sanders Target Version => 3.3
2015-03-07 18:52 Vincent Sanders Description Updated View Revisions
2015-03-07 18:52 Vincent Sanders Additional Information Updated View Revisions
2015-03-07 22:34 Michael Drake Note Added: 0000635
2015-03-08 14:35 Dave Higton Note Added: 0000636
2015-03-08 14:35 Dave Higton Status feedback => assigned
2015-03-08 14:50 Vincent Sanders Status assigned => resolved
2015-03-08 14:50 Vincent Sanders Fixed in Version => 3.3
2015-03-10 23:38 Vincent Sanders Note Added: 0000735
2015-03-10 23:38 Vincent Sanders Status resolved => closed
+Issue History