2019-09-21 10:34 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002279NetSurfJavascriptpublic2015-03-10 23:38
ReporterRichard Porter 
Assigned ToVincent Sanders 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.16
Product Version 
Target Version3.3Fixed in Version3.3 
Summary0002279: Spontaneous crash.
DescriptionNetSurf spontaneously crashed with a Segmentation Fault. No windows were open. I had just drawn a box on the desktop with the mouse (for no particular reason).
TagsNo tags attached.
Fixed in CI build #2623
Reported in CI build #2609
URL of problem pagenone
Attached Files

-Relationships
has duplicate 0002277closed Segmentation Fault 
has duplicate 0000382closedVincent Sanders Crash on closing a window while page is loading 
+Relationships

-Notes
Vincent Sanders

~0000629

Vincent Sanders (administrator)

(33969.710000) content/fetchers/curl.c fetch_curl_done 838: done https://fbstatic-a.akamaihd.net/rsrc.php/v2/yr/r/EC3AsYXXh6Y.css
(33969.710000) content/fetchers/curl.c fetch_curl_done 876: Unknown cURL response code 28
(33969.710000) content/fetchers/curl.c fetch_curl_stop 703: fetch 0x3a9b15a0, url 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yr/r/EC3AsYXXh6Y.css'
(33969.720000) render/html_css.c html_convert_css_callback 113: stylesheet https://fbstatic-a.akamaihd.net/rsrc.php/v2/yr/r/EC3AsYXXh6Y.css failed: Timeout was reached
(33969.720000) render/html_css.c html_convert_css_callback 117: 5 fetches active
(33969.740000) content/content.c content_destroy 386: content 0x3aa1ab88 file:///NetSurf:/Resources/Quirks
(33969.750000) content/content.c content_destroy 386: content 0x3a1f4020 file:///NetSurf:/Resources/AdBlock
(33969.750000) content/content.c content_destroy 386: content 0x3a939e40 file:///NetSurf:/Resources/CSS
(33970.660000) content/fetchers/curl.c fetch_curl_process_headers 771: HTTP status code 200
(33970.790000) content/fetchers/curl.c fetch_curl_done 838: done https://fbstatic-a.akamaihd.net/rsrc.php/v2/yM/r/lkviYnSjDqW.css
(33970.790000) content/fetchers/curl.c fetch_curl_done 876: Unknown cURL response code 28
(33970.790000) content/fetchers/curl.c fetch_curl_stop 703: fetch 0x3a276ef0, url 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yM/r/lkviYnSjDqW.css'
(33970.800000) render/html_css.c html_convert_css_callback 113: stylesheet https://fbstatic-a.akamaihd.net/rsrc.php/v2/yM/r/lkviYnSjDqW.css failed: Timeout was reached
(33970.800000) render/html_css.c html_convert_css_callback 117: 4 fetches active
(33970.800000) content/fetchers/curl.c fetch_curl_done 838: done https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css
(33970.800000) content/fetchers/curl.c fetch_curl_stop 703: fetch 0x3a25a5e8, url 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css'
(33970.880000) content/content.c content__init 80: url https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css -> 0x3a93e7d0
(33970.880000) content/content.c content_add_user 599: content https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css (0x3a93e7d0), user 0x3e344 0x3a25a480
(33971.430000) content/content.c content_convert 281: content https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css (0x3a93e7d0)
(33971.430000) render/html_css.c html_convert_css_callback 105: done stylesheet slot 8 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/y_/r/F3iYq6WfGvg.css'
(33971.430000) render/html_css.c html_convert_css_callback 107: 3 fetches active
(33971.440000) content/fetchers/curl.c fetch_curl_done 838: done https://fbstatic-a.akamaihd.net/rsrc.php/v2/yb/r/RkQKvRjGd5-.css
(33971.440000) content/fetchers/curl.c fetch_curl_done 876: Unknown cURL response code 28
(33971.440000) content/fetchers/curl.c fetch_curl_stop 703: fetch 0x3a244ea0, url 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yb/r/RkQKvRjGd5-.css'
(33971.450000) render/html_css.c html_convert_css_callback 113: stylesheet https://fbstatic-a.akamaihd.net/rsrc.php/v2/yb/r/RkQKvRjGd5-.css failed: Timeout was reached
(33971.450000) render/html_css.c html_convert_css_callback 117: 2 fetches active
(33971.530000) content/fetchers/curl.c fetch_curl_process_headers 771: HTTP status code 200
(33971.550000) content/content.c content__init 80: url https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js -> 0x3a311e98
(33971.560000) content/content.c content_add_user 599: content https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js (0x3a311e98), user 0x3e344 0x3a43ed20
(33971.600000) content/fetchers/curl.c fetch_curl_done 838: done https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js
(33971.600000) content/fetchers/curl.c fetch_curl_stop 703: fetch 0x3a43ede8, url 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js'
(33971.610000) content/content.c content_convert 281: content https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js (0x3a311e98)
(33971.610000) render/html_script.c convert_script_sync_cb 277: script 2 done 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js'
(33971.610000) render/html_script.c convert_script_sync_cb 279: 1 fetches active

Fatal signal received: Segmentation fault

Stack backtrace:

Running thread 0x6aa4ec
  ( 6b2edc) pc: 49c31c lr: bb22c sp: 6b2ee0 __write_backtrace()
  ( 6b2f08) pc: bb1ac lr: 49cc40 sp: 6b2f0c ro_gui_signal()
  ( 6b2f30) pc: 49cc28 lr: 49c91c sp: 6b2f34 __unixlib_exec_sig()
  ( 6b2fa0) pc: 49c434 lr: 49d224 sp: 6b2fa4 __unixlib_raise_signal()
  ( 6b2fb0) pc: 49d128 lr: 39c16c sp: 6b1a00 __h_cback()

  Register dump at 006b2fb4:

    a1: ffffffff a2: 34c18 a3: 0 a4: 21
    v1: 34c18 v2: 3a55b108 v3: 3a250688 v4: 3a43ed20
    v5: 109 v6: 6b1a44 sl: 6b1208 fp: 6b1a18
    ip: 34c21 sp: 6b1a00 lr: 2039c16c pc: a03c6d78
    Mode USR, flags set: NzCvif

  003c6d64 : ..P� : e1500001 : CMP R0,R1
  003c6d68 : ..�� : 80811002 : ADDHI R1,R1,R2
  003c6d6c : ..� : 93e01000 : MVNLS R1,#0
  003c6d70 : �.�� : e58310c8 : STR R1,[R3,#200]
  003c6d74 : .�� : e1a0f00e : MOV PC,R14
  003c6d78 : Resi : 69736552 : LDMVSDB R3!,{R1,R4,R6,R8,R10,R13,R14}^ ; *** ! and ^
  003c6d7c : ze.. : 0000657a : ANDEQ R6,R0,R10,ROR R5
  003c6d80 : ...� : ff000008 : SWINV OS_File ; *** Use of NV
  003c6d84 : .�� : e1a0c00d : MOV R12,R13

  ( 6b1a18) pc: 39c12c lr: 410ce4 sp: 6b1a1c JS_malloc()
  ( 6b1a34) pc: 410cc4 lr: 399444 sp: 6b1a38 js_InflateString()
  ( 6b1a64) pc: 39941c lr: 80808 sp: 6b1a68 JS_EvaluateScript()
  ( 6b1a90) pc: 8079c lr: 9c740 sp: 6b1a94 js_exec()
  ( 6b1abc) pc: 9c470 lr: 3e3ac sp: 6b1ac0 convert_script_sync_cb()
  ( 6b1b00) pc: 3e354 lr: 3285c sp: 6b1b0c hlcache_content_callback()
  ( 6b1b50) pc: 327e8 lr: 32cc0 sp: 6b1b5c content_broadcast()
  ( 6b1bb8) pc: 32c64 lr: 7fc24 sp: 6b1bbc content_set_done()
  ( 6b1bcc) pc: 7fc0c lr: 32f64 sp: 6b1bd0 javascript_convert()
  ( 6b1c34) pc: 32d98 lr: 40948 sp: 6b1c38 content_llcache_callback()
  ( 6b1c6c) pc: 407b8 lr: 40a40 sp: 6b1c70 llcache_object_notify_users()
  ( 6b1c84) pc: 40a14 lr: cfe24 sp: 6b1c88 llcache_catch_up_all_users()
  ( 6b1ca4) pc: cfddc lr: 9dd0 sp: 6b1ca8 schedule_run()
  ( 6b1fe8) pc: 9548 lr: 4aafe4 sp: 6b1fec main()
Vincent Sanders

~0000630

Vincent Sanders (administrator)

Content fetch was started for javascript 'https://fbstatic-a.akamaihd.net/rsrc.php/v2/yx/r/B67rGiOqstH.js' the completion of which happens long after the html docuemnt that started the fetch has gone (and the javascript context it references)

The delay is caused by the css fetches in front of it in the fetch queue timing out.
Vincent Sanders

~0000631

Vincent Sanders (administrator)

I believe I have fixed this, can you try the 2623 CI build and see if it reproduces again?
Richard Porter

~0000632

Richard Porter (reporter)

I have installed 2623 and will add a further note if there's a recurrence.
Vincent Sanders

~0000640

Vincent Sanders (administrator)

after a lot of testing it would seem the underlying cause of this and its related bugs has been found and fixed. If you get a new occurrence of something similar please file a new bug.
Vincent Sanders

~0000733

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2015-03-01 17:57 Richard Porter New Issue
2015-03-01 17:57 Richard Porter File Added: nslog313.zip
2015-03-06 13:28 Vincent Sanders Assigned To => Vincent Sanders
2015-03-06 13:28 Vincent Sanders Status new => confirmed
2015-03-06 13:28 Vincent Sanders Category ABEND => Javascript
2015-03-06 13:28 Vincent Sanders Target Version => 3.3
2015-03-06 13:30 Vincent Sanders Note Added: 0000629
2015-03-06 13:34 Vincent Sanders Note Added: 0000630
2015-03-07 15:57 Vincent Sanders Fixed in CI build # => 2623
2015-03-07 15:57 Vincent Sanders Note Added: 0000631
2015-03-07 15:57 Vincent Sanders Reproducibility have not tried => sometimes
2015-03-07 15:57 Vincent Sanders Status confirmed => feedback
2015-03-07 15:57 Vincent Sanders Resolution open => fixed
2015-03-07 15:57 Vincent Sanders Fixed in Version => 3.3
2015-03-07 16:13 Richard Porter Note Added: 0000632
2015-03-07 16:13 Richard Porter Status feedback => assigned
2015-03-07 16:38 Vincent Sanders Relationship added has duplicate 0002277
2015-03-07 18:43 Vincent Sanders Relationship added has duplicate 0000382
2015-03-07 22:23 Vincent Sanders Status assigned => feedback
2015-03-09 15:22 Vincent Sanders Note Added: 0000640
2015-03-09 15:22 Vincent Sanders Status feedback => resolved
2015-03-10 23:38 Vincent Sanders Note Added: 0000733
2015-03-10 23:38 Vincent Sanders Status resolved => closed
+Issue History