2019-05-26 22:45 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000391NetSurf[All Projects] Generalpublic2015-03-09 17:04
ReporterMartin Avison 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityunable to reproduce 
StatusclosedResolutionfixed 
PlatformIyonixOSRISC OSOS Version5.18
Product Version3.0 
Target VersionFixed in Version3.1 
Summary0000391: Reprodicible crashes on 2 bank websites
DescriptionReproducible crashes when using two banking websites, with both
Javascript disabled and enabled.

Note that the two banks are probably very similar websites, as I
suspect they are both running the same basic website.

I have attached four crash logs in a zip file...

IFJS Intelligent Finance site with Javascript enabled
IFnoJS Intelligent Finance site with Javascript disabled
SJJS St James's Place site with Javascript enabled
SJnoJS St James's Place site with Javascript disabled
Steps To Reproducewww.if.com
     Click on 'Log In' button
     Click on 'Login to Online Banking' button
     --> crash!

www.sjpb.co.uk
     Click on 'Existing clients' button
     Click on 'Login to your account' link
     --> crash!
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3611772 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #1530
Reported in CI build #
URL of problem pagewww.if.com
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000022

Vincent Sanders (administrator)

I have tried this with current CI build http://ci.netsurf-browser.org/builds/riscos/NetSurf-gcc-json-1530.zip and it appears to work. Can you try and confirm if the crash is still occurring for you?
Vincent Sanders

~0000031

Vincent Sanders (administrator)

I am closing this bug as the crash is resolved please use http://bugs.netsurf-browser.org/ to report your failure to login bug as a new issue so it can be tracked properly.

Martin Avison by email

There is good news and bad on this!

I tried the current build you suggested, and indeed (with JS on) I can
now get to the next page
http://www.sjpb.co.uk/existingclients/onlinebanking.asp
without an immediate crash. I then can go to the login page
https://my.sjpbank.co.uk/_mem_bin/Formslogin.asp?EA=Redirect
without problem.

However, when I put in my logon details they are not accepted. And I did
check carefully!

This information is proably little use to you to fix the problem, I am
afraid. However, I can logon using Oregano2 v2.2.18 using web page
https://my.sjpbank.co.uk/_mem_bin/FormsLogin.asp?EA=Redirect

If you can think of anything else I can try, please ask, but I have to be
careful about getting suspended with too many failed logins!

It seems I will have to continue using Oregano for a while longer!
(Although I admit that some functions do not work, and I then have to use
FF on Windows!).

This is all now on RO5.20.
Vincent Sanders

~0000643

Vincent Sanders (administrator)

correctly resolved in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-17 13:44 Vincent Sanders URL of problem page => www.if.com
2013-12-17 13:44 Vincent Sanders Note Added: 0000022
2013-12-17 13:44 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-17 13:44 Vincent Sanders Severity minor => crash
2013-12-17 13:44 Vincent Sanders Reproducibility have not tried => unable to reproduce
2013-12-17 13:44 Vincent Sanders Status assigned => feedback
2013-12-17 13:44 Vincent Sanders Resolution no change required => open
2013-12-17 13:44 Vincent Sanders OS => RISC OS
2013-12-17 13:44 Vincent Sanders OS Version => 5.18
2013-12-17 13:44 Vincent Sanders Platform => Iyonix
2013-12-17 13:44 Vincent Sanders Product Version => 3.0
2013-12-17 13:44 Vincent Sanders Description Updated View Revisions
2013-12-17 13:44 Vincent Sanders Steps to Reproduce Updated View Revisions
2013-12-17 13:44 Vincent Sanders Additional Information Updated View Revisions
2013-12-17 15:26 Vincent Sanders Note Added: 0000031
2013-12-17 15:26 Vincent Sanders Status feedback => resolved
2013-12-17 15:26 Vincent Sanders Resolution open => fixed
2013-12-17 15:26 Vincent Sanders Fixed in Version => 3.1
2015-03-09 17:03 Vincent Sanders Note Added: 0000643
2015-03-09 17:03 Vincent Sanders Status resolved => closed
2015-03-09 17:03 Vincent Sanders Assigned To => Vincent Sanders
2015-03-09 17:04 Vincent Sanders Fixed in CI build # => 1530
+Issue History