2020-09-22 06:15 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002702NetSurf[All Projects] Generalpublic2020-05-27 09:12
ReporterChris Young 
Assigned ToDaniel Silverstone 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.10 
Target Version3.10Fixed in Version3.10 
Summary0002702: Google no longer loads
DescriptionGoogle does not load, it continually cycles with different #spf= numbers in the URL.
Steps To ReproduceVisit http://www.google.co.uk
Additional InformationI think this has been caused by a change on Google's site rather than NetSurf.
TagsNo tags attached.
Fixed in CI build #4972
Reported in CI build #4842
URL of problem pagehttp://www.google.co.uk
Attached Files

-Relationships
duplicate of 0002699confirmed Googkle home page inacessible in RISC OS NetSurf 
+Relationships

-Notes
Vincent Sanders

~0002108

Vincent Sanders (administrator)

as noted on the linked bug this seems to be caused by javascript and slow systems. i think perhaps the spf value has expired by the time the slow systems load the page
Daniel Silverstone

~0002169

Daniel Silverstone (administrator)

We weren't completing the content state machine if an async script completed after the html conversion process had completed. The fix I pushed should deal with that.
Vincent Sanders

~0002226

Vincent Sanders (administrator)

Thankyou for reporting this issue.
We believe this is fixed in the 3.10 release.
If this is not the case please feel free to reopen the issue with additional details.
+Notes

-Issue History
Date Modified Username Field Change
2019-08-31 19:02 Chris Young New Issue
2019-08-31 19:02 Chris Young File Added: ns.log.gz
2019-09-01 13:16 Vincent Sanders Relationship added duplicate of 0002699
2019-10-21 10:40 Vincent Sanders Status new => acknowledged
2019-10-21 10:40 Vincent Sanders Note Added: 0002108
2020-02-21 10:48 Daniel Silverstone Assigned To => Daniel Silverstone
2020-02-21 10:48 Daniel Silverstone Status acknowledged => resolved
2020-02-21 10:48 Daniel Silverstone Resolution open => fixed
2020-02-21 10:48 Daniel Silverstone Fixed in Version => 3.10
2020-02-21 10:48 Daniel Silverstone Fixed in CI build # => 4972
2020-02-21 10:48 Daniel Silverstone Note Added: 0002169
2020-05-27 09:12 Vincent Sanders Status resolved => closed
2020-05-27 09:12 Vincent Sanders Note Added: 0002226
+Issue History