2020-07-05 12:37 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002690NetSurfLayoutpublic2020-05-27 09:13
ReporterMichael Drake 
Assigned ToMichael Drake 
SeveritymajorReproducibilityunable to reproduce 
StatusclosedResolutionfixed 
PlatformAnyOSOS Version
Product Version 
Target Version3.10Fixed in Version3.10 
Summary0002690: Animated GIF causes box_coords to explode
Descriptionbox_coords walks up the box tree to find the absolute position of the box.

If we hit a float box, we expect to find a box with it's float_children set.

If not, the box tree is broken.

Daniel observed this happening on the 500 sites test run.

The problem is not easily reproducible.
Steps To ReproduceVisit https://www.netsons.com/

Although, when I load it, I don't even get the animated GIF throbbers that Daniel gets when he loads it.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem pagehttps://www.netsons.com/
Attached Files

-Relationships
+Relationships

-Notes
Michael Drake

~0002066

Michael Drake (administrator)

This change may or may not help:

http://source.netsurf-browser.org/netsurf.git/commit/?id=be23d522db03f412bc9a855aac7598419336d4f1

Either way, it's generally more optimal.
Michael Drake

~0002067

Michael Drake (administrator)

Note:

Neither float_children or float_container are assigned until layout.

However, it doesn't make sense to call box_coords on something before layout has happened.
Michael Drake

~0002068

Michael Drake (administrator)

Note:

We don't set float_children or float_container until layout because layout is the first pass over the box tree that works out which boxes will establish a new block formatting context.
Michael Drake

~0002069

Michael Drake (administrator)

Potentially fixed by:

http://source.netsurf-browser.org/netsurf.git/commit/?id=5e45c4498c0a8a24330864b3d4c68ffe891ce15e
Vincent Sanders

~0002227

Vincent Sanders (administrator)

Thankyou for reporting this issue.
We believe this is fixed in the 3.10 release.
If this is not the case please feel free to reopen the issue with additional details.
+Notes

-Issue History
Date Modified Username Field Change
2019-08-06 09:21 Michael Drake New Issue
2019-08-06 09:23 Michael Drake Note Added: 0002066
2019-08-06 09:26 Michael Drake Note Added: 0002067
2019-08-06 09:27 Michael Drake Note Added: 0002068
2019-08-06 09:43 Michael Drake Note Added: 0002069
2019-08-06 10:14 Michael Drake Status new => acknowledged
2020-02-21 10:17 Michael Drake Assigned To => Michael Drake
2020-02-21 10:17 Michael Drake Reproducibility have not tried => unable to reproduce
2020-02-21 10:17 Michael Drake Status acknowledged => resolved
2020-02-21 10:17 Michael Drake Resolution open => fixed
2020-02-21 10:17 Michael Drake Fixed in Version => 3.10
2020-05-27 09:13 Vincent Sanders Status resolved => closed
2020-05-27 09:13 Vincent Sanders Note Added: 0002227
+Issue History