2024-07-16 00:14 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002635NetSurfAmiga-specificpublic2019-07-19 09:31
ReporterGeorge Sokianos 
Assigned ToChris Young 
Product Version3.8 
Target VersionFixed in Version3.9 
Summary0002635: One config can be used only
DescriptionIf you start Netsurf 3.8 with a configuration and, while it is still running, start from Shell, using the USERSDIR parameter, then the second run is ignored and only the first config is used.
Steps To ReproduceYou need to have two different configurations to test that.

1. Start Netsurf and don't close it
2. Open shell and run APPDIR:Netsurf USERSDIR="<set here the folder of the second config>"

You will see that the second run of NetSurf uses the configuration of the first run.
Additional InformationRunning Netsurf 3.8 under AmigaOS 4.1 FE
TagsNo tags attached.
Fixed in CI build #4563
Reported in CI build #
URL of problem page
Attached Files


Chris Young


Chris Young (developer)

I don't think this will ever work, as only one NetSurf application will run at a time, and therefore only one config. I'm not inclined to change this behaviour.
Chris Young


Chris Young (developer)

You may find specifying FORCE will do what you want.
George Sokianos


George Sokianos (reporter)

Tried the FORCE switch, which makes the NetSurf use the alternative configuration, and worked great. But it seems it ignores the URL parameter and opens the home page.
Chris Young


Chris Young (developer)

Fixed in 4563
Vincent Sanders


Vincent Sanders (administrator)

we believe this issue has been resolved in NetSurf 3.9

-Issue History
Date Modified Username Field Change
2019-02-16 16:45 George Sokianos New Issue
2019-02-16 17:37 Vincent Sanders Assigned To => Chris Young
2019-02-16 17:37 Vincent Sanders Status new => acknowledged
2019-02-17 09:22 Chris Young Status acknowledged => confirmed
2019-02-17 09:22 Chris Young Note Added: 0001887
2019-02-17 09:43 Chris Young Status confirmed => feedback
2019-02-17 09:43 Chris Young Note Added: 0001888
2019-02-18 18:20 George Sokianos Note Added: 0001890
2019-02-18 18:20 George Sokianos Status feedback => assigned
2019-02-18 18:43 Chris Young Status assigned => confirmed
2019-03-02 23:32 Chris Young Status confirmed => resolved
2019-03-02 23:32 Chris Young Resolution open => fixed
2019-03-02 23:32 Chris Young Fixed in Version => 3.9
2019-03-02 23:32 Chris Young Fixed in CI build # => 4563
2019-03-02 23:32 Chris Young Note Added: 0001895
2019-07-19 09:31 Vincent Sanders Status resolved => closed
2019-07-19 09:31 Vincent Sanders Note Added: 0002016
+Issue History