MantisBT - NetSurf
View Issue Details
0002635NetSurfAmiga-specificpublic2019-02-16 16:452019-03-02 23:32
ReporterGeorge Sokianos 
Assigned ToChris Young 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version3.8 
Target VersionFixed in Version3.9 
Fixed in CI build #4563
Reported in CI build #
URL of problem page
Summary0002635: One config can be used only
DescriptionIf you start Netsurf 3.8 with a configuration and, while it is still running, start from Shell, using the USERSDIR parameter, then the second run is ignored and only the first config is used.
Steps To ReproduceYou need to have two different configurations to test that.

1. Start Netsurf and don't close it
2. Open shell and run APPDIR:Netsurf USERSDIR="<set here the folder of the second config>"

You will see that the second run of NetSurf uses the configuration of the first run.
Additional InformationRunning Netsurf 3.8 under AmigaOS 4.1 FE
TagsNo tags attached.
Attached Files

Notes
(0001887)
Chris Young   
2019-02-17 09:22   
I don't think this will ever work, as only one NetSurf application will run at a time, and therefore only one config. I'm not inclined to change this behaviour.
(0001888)
Chris Young   
2019-02-17 09:43   
You may find specifying FORCE will do what you want.
(0001890)
George Sokianos   
2019-02-18 18:20   
Tried the FORCE switch, which makes the NetSurf use the alternative configuration, and worked great. But it seems it ignores the URL parameter and opens the home page.
(0001895)
Chris Young   
2019-03-02 23:32   
Fixed in 4563

Issue History
2019-02-16 16:45George SokianosNew Issue
2019-02-16 17:37Vincent SandersAssigned To => Chris Young
2019-02-16 17:37Vincent SandersStatusnew => acknowledged
2019-02-17 09:22Chris YoungStatusacknowledged => confirmed
2019-02-17 09:22Chris YoungNote Added: 0001887
2019-02-17 09:43Chris YoungStatusconfirmed => feedback
2019-02-17 09:43Chris YoungNote Added: 0001888
2019-02-18 18:20George SokianosNote Added: 0001890
2019-02-18 18:20George SokianosStatusfeedback => assigned
2019-02-18 18:43Chris YoungStatusassigned => confirmed
2019-03-02 23:32Chris YoungStatusconfirmed => resolved
2019-03-02 23:32Chris YoungResolutionopen => fixed
2019-03-02 23:32Chris YoungFixed in Version => 3.9
2019-03-02 23:32Chris YoungFixed in CI build # => 4563
2019-03-02 23:32Chris YoungNote Added: 0001895