2019-01-16 17:27 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002392NetSurfAmiga-specificpublic2016-02-16 14:13
Reporterxenic 
Assigned ToChris Young 
SeverityfeatureReproducibilityN/A 
StatusclosedResolutionfixed 
Product Version3.4 
Target Version3.4Fixed in Version3.4 
Summary0002392: Please add a prefs setting or argument/tooltype to set the location of the 'user' directory.
DescriptionPlease add a prefs setting or argument/tooltype to set the location of the 'user' directory. I run Netsurf from a locked (write protected) partition and want to put settings (user directory) on a data partition.
TagsNo tags attached.
Fixed in CI build #3225
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001109

Chris Young (developer)

I've added a ToolType "USERSDIR" which will be in the next CI build.
Chris Young

~0001110

Chris Young (developer)

Note to self:
Adding a command line argument will be trickier as we can only call ReadArgs() once, and this currently happens after the user options are read (ie. too late). It implements some witchcraft to pass args to the core which can only be done at this time.
The function will need splitting out so it parses ReadArgs early but keeps NSOPTS/M alive until the core argument parsing can be done.
xenic

~0001113

xenic (reporter)

Note from xenic:
Don't knock yourself out getting a command line arg to work. I do run Netsurf from a toolbar (command line) but I can just 'wbrun' it so it gets the 'USERDIR' tooltype from the icon.
Chris Young

~0001115

Chris Young (developer)

The issue is more that it needs to be easy to run with debug output no matter where the user dirs are stored. So, either log capture needs to be added to WB execution, or a users dir option needs to be added to arguments.
Chris Young

~0001120

Chris Young (developer)

Added in build 3225 as tooltype and commandline arg "USERSDIR".
Vincent Sanders

~0001250

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-11-15 15:40 xenic New Issue
2015-11-15 17:43 Chris Young Status new => closed
2015-11-15 17:43 Chris Young Assigned To => Chris Young
2015-11-15 17:43 Chris Young Resolution open => suspended
2015-11-15 17:45 Chris Young Project Buildsystem => NetSurf
2015-11-15 17:46 Chris Young Status closed => feedback
2015-11-15 17:46 Chris Young Resolution suspended => reopened
2015-11-15 17:46 Chris Young Status feedback => acknowledged
2015-11-15 17:47 Chris Young Resolution reopened => open
2015-11-15 17:47 Chris Young Category General => Amiga-specific
2015-11-15 17:47 Chris Young Product Version => 3.4
2015-11-15 17:47 Chris Young Target Version => 3.4
2015-11-22 00:15 Chris Young Note Added: 0001109
2015-11-22 00:15 Chris Young Severity minor => feature
2015-11-22 00:15 Chris Young Reproducibility have not tried => N/A
2015-11-22 00:21 Chris Young Note Added: 0001110
2015-11-22 19:13 xenic Note Added: 0001113
2015-11-22 23:55 Chris Young Note Added: 0001115
2015-11-25 00:18 Chris Young Fixed in CI build # => 3225
2015-11-25 00:18 Chris Young Note Added: 0001120
2015-11-25 00:18 Chris Young Status acknowledged => resolved
2015-11-25 00:18 Chris Young Fixed in Version => 3.4
2015-11-25 00:18 Chris Young Resolution open => fixed
2016-02-16 14:13 Vincent Sanders Note Added: 0001250
2016-02-16 14:13 Vincent Sanders Status resolved => closed
+Issue History