MantisBT - NetSurf
View Issue Details
0002392NetSurfAmiga-specificpublic2015-11-15 15:402016-02-16 14:13
Assigned ToChris Young 
PlatformOSOS Version
Product Version3.4 
Target Version3.4Fixed in Version3.4 
Fixed in CI build #3225
Reported in CI build #
URL of problem page
Summary0002392: Please add a prefs setting or argument/tooltype to set the location of the 'user' directory.
DescriptionPlease add a prefs setting or argument/tooltype to set the location of the 'user' directory. I run Netsurf from a locked (write protected) partition and want to put settings (user directory) on a data partition.
TagsNo tags attached.
Attached Files

Chris Young   
2015-11-22 00:15   
I've added a ToolType "USERSDIR" which will be in the next CI build.
Chris Young   
2015-11-22 00:21   
Note to self:
Adding a command line argument will be trickier as we can only call ReadArgs() once, and this currently happens after the user options are read (ie. too late). It implements some witchcraft to pass args to the core which can only be done at this time.
The function will need splitting out so it parses ReadArgs early but keeps NSOPTS/M alive until the core argument parsing can be done.
2015-11-22 19:13   
Note from xenic:
Don't knock yourself out getting a command line arg to work. I do run Netsurf from a toolbar (command line) but I can just 'wbrun' it so it gets the 'USERDIR' tooltype from the icon.
Chris Young   
2015-11-22 23:55   
The issue is more that it needs to be easy to run with debug output no matter where the user dirs are stored. So, either log capture needs to be added to WB execution, or a users dir option needs to be added to arguments.
Chris Young   
2015-11-25 00:18   
Added in build 3225 as tooltype and commandline arg "USERSDIR".
Vincent Sanders   
2016-02-16 14:13   
Confirmed fixed in 3.4 release

Issue History
2015-11-15 15:40xenicNew Issue
2015-11-15 17:43Chris YoungStatusnew => closed
2015-11-15 17:43Chris YoungAssigned To => Chris Young
2015-11-15 17:43Chris YoungResolutionopen => suspended
2015-11-15 17:45Chris YoungProjectBuildsystem => NetSurf
2015-11-15 17:46Chris YoungStatusclosed => feedback
2015-11-15 17:46Chris YoungResolutionsuspended => reopened
2015-11-15 17:46Chris YoungStatusfeedback => acknowledged
2015-11-15 17:47Chris YoungResolutionreopened => open
2015-11-15 17:47Chris YoungCategoryGeneral => Amiga-specific
2015-11-15 17:47Chris YoungProduct Version => 3.4
2015-11-15 17:47Chris YoungTarget Version => 3.4
2015-11-22 00:15Chris YoungNote Added: 0001109
2015-11-22 00:15Chris YoungSeverityminor => feature
2015-11-22 00:15Chris YoungReproducibilityhave not tried => N/A
2015-11-22 00:21Chris YoungNote Added: 0001110
2015-11-22 19:13xenicNote Added: 0001113
2015-11-22 23:55Chris YoungNote Added: 0001115
2015-11-25 00:18Chris YoungFixed in CI build # => 3225
2015-11-25 00:18Chris YoungNote Added: 0001120
2015-11-25 00:18Chris YoungStatusacknowledged => resolved
2015-11-25 00:18Chris YoungFixed in Version => 3.4
2015-11-25 00:18Chris YoungResolutionopen => fixed
2016-02-16 14:13Vincent SandersNote Added: 0001250
2016-02-16 14:13Vincent SandersStatusresolved => closed