2019-01-22 03:02 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002343NetSurf[All Projects] Generalpublic2016-02-16 14:07
ReporterHarriet Bazley 
Assigned ToDaniel Silverstone 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformARMOSRISC OSOS Version5.19
Product Version 
Target VersionFixed in Version3.4 
Summary0002343: Netsurf isn't saving JavaScript status
DescriptionAs of my most recent download (v2875) Netsurf no longer seems to be saving the JavaScript on/off state to its Choices file. Altering the state of the 'Hide advertisements icon, for example, alters the content of the file saved: selecting 'Disable JavaScript' only affects the current session and the status is not saved to disc on exit.

The effect is that Netsurf repeatedly defaults without warning to JavaScript-enabled status, causing pages to hang....
Steps To ReproduceOpen configuration window. Select Content->Content blocking->Disable JavaScript
Quit Netsurf.

Reload. Icon is no longer selected. Inspection of <Choices$Write>.WWW.NetSurf.Choices shows no configuration line has been written to file.
Additional InformationNetsurf v2875, RISC OS 5.21, ARMini.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2875
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Daniel Silverstone

~0000883

Daniel Silverstone (administrator)

Yep, this is currently the behaviour we expect. We're testing a new JS implementation and part of this involves forcing it on all the time.

We'll turn it back to choices-controlled when we're back to feature parity. For now, you can simply turn JS off every time you load the browser instead.
Harriet Bazley

~0000885

Harriet Bazley (reporter)

This is a bit complicated for my mother, I'm afraid ("The browser isn't working!")

The safest thing to do is probably to revert to an earlier version for the moment.
Daniel Silverstone

~0000886

Daniel Silverstone (administrator)

Aye, sorry, but CI releases are not meant for non-technical users anyway, since it's quite hard to get good bug reports out of them :-)

I hope to be in a position to disable the 'force-on' fairly soon, but it's a long slog back to feature parity with our JSAPI implementation.
Daniel Silverstone

~0000887

Daniel Silverstone (administrator)

Oh, as an additional comment, I'd love some examples of pages which hang with JS on, so I can start to debug why :-)
Harriet Bazley

~0000890

Harriet Bazley (reporter)

This is the last one we encountered: https://www.fanfiction.net/topic/70706/22069226/13/#138517133
Dave Higton

~0001021

Dave Higton (developer)

Last edited: 2015-11-02 22:45

View 2 revisions

The URL cited by Harriet does not hang with JS on, in CI#3046. If it appeared to do so before, this is probably another manifestation of the slow regex interpreter that was fixed recently.

Harriet Bazley

~0001022

Harriet Bazley (reporter)

Yes, this is the same bug that was fixed for that site as 2364/2366.
Dave Higton

~0001189

Dave Higton (developer)

This has been fixed as of quite a few versions ago, getting ready for another release.
Vincent Sanders

~0001234

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-08-10 22:43 Harriet Bazley New Issue
2015-08-11 10:16 Daniel Silverstone Note Added: 0000883
2015-08-11 10:16 Daniel Silverstone Assigned To => Daniel Silverstone
2015-08-11 10:16 Daniel Silverstone Status new => confirmed
2015-08-11 10:16 Daniel Silverstone Category RISC OS-specific => General
2015-08-11 10:16 Daniel Silverstone Description Updated View Revisions
2015-08-11 10:16 Daniel Silverstone Steps to Reproduce Updated View Revisions
2015-08-11 13:18 Harriet Bazley Note Added: 0000885
2015-08-11 13:33 Daniel Silverstone Note Added: 0000886
2015-08-11 14:15 Daniel Silverstone Note Added: 0000887
2015-08-12 08:59 Harriet Bazley Note Added: 0000890
2015-11-02 22:45 Dave Higton Note Added: 0001021
2015-11-02 22:45 Dave Higton Note Edited: 0001021 View Revisions
2015-11-03 00:26 Harriet Bazley Note Added: 0001022
2016-02-04 22:08 Dave Higton Note Added: 0001189
2016-02-04 22:08 Dave Higton Status confirmed => resolved
2016-02-04 22:08 Dave Higton Resolution open => fixed
2016-02-04 22:08 Dave Higton Description Updated View Revisions
2016-02-04 22:08 Dave Higton Steps to Reproduce Updated View Revisions
2016-02-16 14:06 Vincent Sanders Note Added: 0001234
2016-02-16 14:06 Vincent Sanders Fixed in Version => 3.4
2016-02-16 14:06 Vincent Sanders Description Updated View Revisions
2016-02-16 14:06 Vincent Sanders Steps to Reproduce Updated View Revisions
2016-02-16 14:07 Vincent Sanders Status resolved => closed
+Issue History