2019-11-23 00:04 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002264NetSurf[All Projects] Generalpublic2015-03-10 23:40
ReporterChris Young 
Assigned ToMichael Drake 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.3 
Target Version3.3Fixed in Version3.3 
Summary0002264: Hotlist not saving
DescriptionWhen updating the hotlist, on exit it creates the Hotlist-bk file, but this never gets moved back to Hotlist.

The log suggests the existing Hotlist isn't being deleted (maybe it is locked/in use?)
Steps To ReproduceLoad NetSurf, update hotlist, quit.
Additional Information(27.377755) desktop/hotlist.c hotlist_fini 1277: Finalising hotlist
(27.390008) desktop/hotlist.c hotlist_save 942: Error renaming hotlist: File exists.
(27.390088) desktop/hotlist.c hotlist_fini 1282: Problem saving the hotlist.
(27.391575) desktop/hotlist.c hotlist_fini 1294: Finalised hotlist
TagsNo tags attached.
Fixed in CI build #2590
Reported in CI build #2576
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Michael Drake

~0000598

Michael Drake (administrator)

This was caused by the non-POSIX behaviour of rename() on AmigaOS. If you're supposed to be using a POSIX library on AmigaOS, you should file a bug against it.

We now call remove() first, but there is still a race condition on for non-POSIX systems; if a hotlist file is created between remove() and rename(), then rename() will still fail.
Vincent Sanders

~0000739

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2015-01-31 14:11 Chris Young New Issue
2015-01-31 14:11 Chris Young Status new => assigned
2015-01-31 14:11 Chris Young Assigned To => Michael Drake
2015-02-03 10:35 Michael Drake Fixed in CI build # => 2590
2015-02-03 10:35 Michael Drake Note Added: 0000598
2015-02-03 10:35 Michael Drake Status assigned => resolved
2015-02-03 10:35 Michael Drake Resolution open => fixed
2015-02-03 10:35 Michael Drake Fixed in Version => 3.3
2015-02-03 10:35 Michael Drake Description Updated View Revisions
2015-02-03 10:35 Michael Drake Additional Information Updated View Revisions
2015-03-10 23:40 Vincent Sanders Note Added: 0000739
2015-03-10 23:40 Vincent Sanders Status resolved => closed
+Issue History