2019-03-26 21:24 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002250NetSurf[All Projects] Generalpublic2015-03-10 23:42
ReporterMichael Drake 
Assigned ToVincent Sanders 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformGTKOSLinuxOS VersionLinux
Product Version3.3 
Target Version3.3Fixed in Version3.3 
Summary0002250: SIGFPE in llcache_finalise
DescriptionProgram received signal SIGFPE, Arithmetic exception.
0x000000000045445a in llcache_finalise () at content/llcache.c:3277
3277IItotal_bandwidth = (llcache->total_written * 1000) / llcache->total_elapsed;
(gdb) bt
#0 0x000000000045445a in llcache_finalise () at content/llcache.c:3277
#1 0x0000000000452b15 in hlcache_finalise () at content/hlcache.c:621
0000002 0x0000000000472f2e in netsurf_exit () at desktop/netsurf.c:268
#3 0x0000000000488eb0 in main (argc=1, argv=0x7fffffffde58) at gtk/gui.c:1288
Steps To ReproduceI quit NetSurf. I think it had only shown the welcome page since starting up.
TagsNo tags attached.
Fixed in CI build #2508
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000564

Vincent Sanders (administrator)

when llcache statistics are computed they cannot produce a division by zero error
Vincent Sanders

~0000748

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2015-01-03 00:30 Michael Drake New Issue
2015-01-03 00:30 Michael Drake Status new => assigned
2015-01-03 00:30 Michael Drake Assigned To => Vincent Sanders
2015-01-03 15:19 Vincent Sanders Fixed in CI build # => 2508
2015-01-03 15:19 Vincent Sanders Note Added: 0000564
2015-01-03 15:19 Vincent Sanders Reproducibility random => always
2015-01-03 15:19 Vincent Sanders Status assigned => resolved
2015-01-03 15:19 Vincent Sanders Resolution open => fixed
2015-01-03 15:19 Vincent Sanders Fixed in Version => 3.3
2015-01-16 09:04 Vincent Sanders Target Version => 3.3
2015-03-10 23:42 Vincent Sanders Note Added: 0000748
2015-03-10 23:42 Vincent Sanders Status resolved => closed
+Issue History