2019-01-22 03:02 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002159NetSurfGTK-specificpublic2015-03-10 11:12
Reporterjohndory 
Assigned ToVincent Sanders 
SeveritytrivialReproducibilityalways 
StatusclosedResolutionfixed 
PlatformLinuxOSArch linuxOS VersionLinux 3.15.1-1-Arch #1 SMP PREEM
Product Version3.2 
Target VersionFixed in Version3.2 
Summary0002159: nsgtk crashes on selecting view source on the default page
DescriptionThe browser_window_create lines in browser.c:
if (!(flags & BW_CREATE_HISTORY)) {
    if (!(flags & BW_CREATE_CLONE) || existing == NULL) {
will always assert because there is no BW_CREATE_HISTORY, or BW_CREATE_CLONE flag in the gtk/dialogs/source.c:
Steps To Reproduce1) Created user, git downloaded ns and libs.
2) Installed to cusom location. PREFIX=/home/user/local
3) Setup PKG_CONFIG_PATH=/home/user/local/lib/pkgconfig & PATH=/home/user/local/bin
4) Compile libs, compile nsgtk
5) Setup NETSURFRES=/home/user/local/share/netsurf
6) cd to home dir, run netsurf, click 'view', choose 'view source', boom.
 
Additional Informationcreated a simple patch and works, however I'm not confident on whether the issue is address properly.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files
  • diff file icon report_0001.diff (611 bytes) 2014-06-26 13:30 -
    diff --git a/gtk/dialogs/source.c b/gtk/dialogs/source.c
    index ab6bb5f..7a76d77 100644
    --- a/gtk/dialogs/source.c
    +++ b/gtk/dialogs/source.c
    @@ -309,8 +309,9 @@ void nsgtk_source_tab_init(GtkWindow *parent, struct browser_window *bw)
     /* HACK 01: Crash will occur if browser if opened and view source is chosen for inbuilt
     	    html page, the absense of BW_CREATE_HISTORY and the Window structure being
     	    set double wammies here
    - */
     		error = browser_window_create(BW_CREATE_TAB,
    + */
    +		error = browser_window_create(BW_CREATE_TAB | BW_CREATE_HISTORY,
     					      url,
     					      NULL,
     					      bw,
    
    diff file icon report_0001.diff (611 bytes) 2014-06-26 13:30 +

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000403

Vincent Sanders (administrator)

I am completely unable to reproduce this either from the about:welcome default or about:blank

can you run netsurf with -v and attach the resulting log to this bug please?
Vincent Sanders

~0000417

Vincent Sanders (administrator)

OK to reproduce this needs to be the blank window not the welcome page
Vincent Sanders

~0000717

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-06-26 13:30 johndory New Issue
2014-06-26 13:30 johndory File Added: report_0001.diff
2014-06-26 14:13 Vincent Sanders Assigned To => Vincent Sanders
2014-06-26 14:13 Vincent Sanders Status new => acknowledged
2014-06-26 14:13 Vincent Sanders Product Version => 3.2
2014-06-26 14:13 Vincent Sanders Description Updated View Revisions
2014-06-26 14:13 Vincent Sanders Steps to Reproduce Updated View Revisions
2014-07-08 13:22 Vincent Sanders Note Added: 0000403
2014-07-08 13:22 Vincent Sanders Reproducibility always => unable to reproduce
2014-07-08 13:22 Vincent Sanders Status acknowledged => feedback
2014-07-19 10:54 Vincent Sanders Note Added: 0000417
2014-07-19 10:54 Vincent Sanders Reproducibility unable to reproduce => always
2014-07-19 10:54 Vincent Sanders Status feedback => confirmed
2014-07-21 00:20 Vincent Sanders Status confirmed => resolved
2014-07-21 00:20 Vincent Sanders Resolution open => fixed
2014-07-21 00:20 Vincent Sanders Fixed in Version => 3.2
2015-03-10 11:12 Vincent Sanders Note Added: 0000717
2015-03-10 11:12 Vincent Sanders Status resolved => closed
+Issue History