2019-01-22 02:58 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002131NetSurfAmiga-specificpublic2015-03-10 11:03
Reporterfreddy omholt 
Assigned ToChris Young 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaNGOSOS4OS Version4.1.6
Product Version3.1 
Target Version3.2Fixed in Version3.2 
Summary0002131: hotlist management
DescriptionCrash in hotlist management
Steps To Reproducewhen download the latest, rin it sys:internet\Netsurf. everything is fast and smooth. first load up of netsurt went ok, checked fonts, end the startup.

so now it work. in default mode.

i do now a system reboot. just for retest.

start up netsurf, i visit www.Amigans.net, loaded great.

so then, i press the bookmark "Star" on the top left to have saved the site, the i look up hotlist windows, there you have tree chooses.

i just playing around, and tried to drag the hotlist bar to the browser, (trying to make a bookmark toolbar) then it crashes, i i have tried it 3-4 times, everything goes perfekt until i try my nasty drag.

i wasen't sure if netsuft had an bookmark add-on bar in man gui, so it just tred
Additional Informationthis i is my first bug report for any software, so go easy on me:)
TagsNo tags attached.
Fixed in CI build #1906
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0000347

Chris Young (developer)

Freddy,

NetSurf does have a bookmark toolbar, in the hotlist window you just need to drag the entries into the "Hotlist toolbar" folder. The toolbar will appear when the hotlist window is closed (it auto-hides when there are no entries).

I will look into the crash. You should be able to drag entries into the browser window to open them in that window/tab. I always drag to the left, it may be that dragging upwards is the problem.

Chris
Chris Young

~0000348

Chris Young (developer)

I can reproduce a similar crash by dragging a folder rather than a hotlist entry into the browser window.
Any items dragged up or down are moved in the hotlist irrespective of whether they were dropped inside or outside the hotlist window, so that needs fixing too.
Chris Young

~0000349

Chris Young (developer)

I've fixed the entries moving even though they've been dragged outside the window, in CI build 1903.

Michael - the crashing appears to be caused by hotlist_get_selection casting folders to a hotlist_entry and thus causing garbage to be returned for the nsurl. The same bug occurs in global_history too.
Michael Drake

~0000350

Michael Drake (administrator)

Chris: thanks should be fixed now.

If the original issue is fixed please close the bug.

(Amiga's the only front end using that API, so I can't test it myself.)
Vincent Sanders

~0000700

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-05-23 06:18 freddy omholt New Issue
2014-05-23 06:18 freddy omholt File Added: Crashlog_NetSurf_2014-05-22_21-26-39.txt
2014-05-23 10:01 Chris Young Note Added: 0000347
2014-05-23 10:01 Chris Young Assigned To => Chris Young
2014-05-23 10:01 Chris Young Status new => assigned
2014-05-23 13:42 Chris Young Status assigned => acknowledged
2014-05-23 13:44 Chris Young Target Version => 3.2
2014-05-23 16:52 Chris Young Note Added: 0000348
2014-05-23 16:52 Chris Young Status acknowledged => confirmed
2014-05-23 16:52 Chris Young Steps to Reproduce Updated View Revisions
2014-05-24 10:57 Chris Young Note Added: 0000349
2014-05-24 10:57 Chris Young Assigned To Chris Young => Michael Drake
2014-05-24 10:57 Chris Young Status confirmed => assigned
2014-05-24 14:26 Michael Drake Note Added: 0000350
2014-05-24 14:26 Michael Drake Assigned To Michael Drake => Chris Young
2014-05-24 14:26 Michael Drake Steps to Reproduce Updated View Revisions
2014-05-24 15:58 Chris Young Fixed in CI build # => 1906
2014-05-24 15:58 Chris Young Status assigned => resolved
2014-05-24 15:58 Chris Young Fixed in Version => 3.2
2014-05-24 15:58 Chris Young Resolution open => fixed
2015-03-10 11:03 Vincent Sanders Note Added: 0000700
2015-03-10 11:03 Vincent Sanders Status resolved => closed
+Issue History