2019-09-21 21:09 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000637NetSurf[All Projects] Generalpublic2006-06-23 20:15
Reporterjtytgat 
Assigned ToSourceforge Import placeholder 
SeverityminorReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000637: Window iconize no longer works for osnews.com
DescriptionThis one is rather odd :

1. Clean <Wimp$ScrapDir>.WWW.NetSurf dir
2. Start NetSurf 27 Mar 2006 01:15
3. Open surf window and type osnews.com
4. Let it load all its data + relayout
5. Click on window iconize button -> window closes but no icon on the
pinboard.

Using other URLs like www.drobe.co.uk, etc works. What's so special
about osnews.com ? ;-)

Using RiscPC Adjust, ViewFinder.
Additional Informationrjek added a note on Fri Jun 23 23:48:01 2006

Logged In: YES
user_id=893271

I've added a workaround to NetSurf for this, for the people
who aren't likely to be using or seeing Pinboard 1.01
anytime soon.

It also appears to be tricky to reproduce on RISC OS 5,
although there are stories and myths of similar things
happening. My workaround doesn't check for RISC OS 5, but I
doubt users will notice the odd occation where the text is
truncated a little more zealously than usual.

jtytgat added a note on Fri Jun 23 20:15:15 2006

Logged In: YES
user_id=1420374

It is confirmed as an OS bug (so it is not a NetSurf bug)
and apparently fixed in RISCOS Ltd's Pinboard v1.01. No
need to let this remain open.

rjek added a note on Wed Jun 21 22:24:43 2006

Logged In: YES
user_id=893271

This does appear to be an OS bug. I have reproduced it with
!Edit. Here's how:

1. Create a new Edit window. Save it as "iiiiiiiiiiiiiii"
2. Create another. Save it as "mmmmmmmmmmmmmmm"
3. Iconise both windows.

The "m" one won't appear. I suspect this has something to
do with the Pinboard truncating at a number of characters,
rather than a number of pixels. This would also explain why
it works just fine at different point sizes and different
fonts, and why some sites work and others do not.

Given this isn't a bug in NetSurf, I have reduced its
priority to the lowest, incase Adrian can thing of some
cunning work around. We might want to experiment to see
precisely how many pixels, etc, causes it to fail, and make
sure we truncate it for the Pinboard instead.

jtytgat added a note on Wed Jun 21 21:43:13 2006

Logged In: YES
user_id=1420374

The desktop font choice is indeed the clue we were looking
for. I'm currently using Homerton.Bold at 12 point (aspect
100%) and then the bug is reproducable. 11 point and lower
makes iconizing work like expected, 12 point and greater
the iconizng no longer works so the trigger is somewhere
between 11 and 12 point. Are we talking about a RISC OS
bug ?

pnyoung added a note on Wed Jun 21 09:42:19 2006

Logged In: YES
user_id=1386864

This was aired on the Iyo mailing list a while back. It seems to be solved by changing or reducing the size of the desktop font. I had it with other sites, and it doesn't happen here with Homerton 11pt as the desktop font.

Best wishes,

Peter.


jtytgat added a note on Sun Jun 18 19:41:10 2006

Logged In: YES
user_id=1420374

Still reproducable with NetSurf build 15 Jun 2006 16:00.
Doesn't this have to do with short length of the URL ?

jtytgat added a note on Mon Apr 3 21:46:49 2006

Logged In: YES
user_id=1420374

This problem got introduced somewhere between NetSurf build
16 Mar 2006 23:45 (= goes fine) and 27 Mar 2006 00:30 (=
next build I took a copy off and there the iconisation of
osnews.com does not happen).

jtytgat added a note on Mon Apr 3 21:40:49 2006

Logged In: YES
user_id=1420374

Still reproducable with 31 Mar 2006 10:45 build. I even
removed my NetSurf choices directory. Tried 256/32K/16M
modes. Always goes wrong with osnews.com (both with shift
close-click or clicking on the iconize button), but not
with drobe.co.uk or any other website I tried.

I also tried to remove the pinboard backdrop (a jpeg file)
but that didn't make a difference.

It is not that there is an invisible iconized icon, it is
simply not there because iconising other windows will not
leave a gap for the supposely invisible icon.

Very odd (and annoying).

rjek added a note on Mon Apr 3 12:04:47 2006

Logged In: YES
user_id=893271

I am unable to reproduce this on my RiscPC - the icon
appears as a thumbnail of the page without issue (I followed
your steps exactly, including emptying NetSurf's scrap
directory.

I am using CVS head, and I used Shift-Close, however. Can
you try again with the latest version?

There is one issue in that there are currently only
"iconised" borders around the thumbnails on RISC OS 5,
meaning that it's feasable that an icon might appear
completely invisible.

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1461036 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
+Issue History