2019-12-07 00:26 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000483NetSurf[All Projects] Generalpublic2013-12-18 18:03
ReporterSourceforge Import placeholder 
Assigned To 
SeverityminorReproducibilityhave not tried 
StatusacknowledgedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000483: Session cookies not created for local website
Descriptionalan@adamshome.org.uk.
I am developing a website with a login script. That script uses
session_register("myusername");
$_SESSION['login_user']=$myusername;

A check later does
$login_session=$row['login_user'];
if (!isset($login_session)) { <report no login> }
This works in IE, Firefox, Safari and Chrome. In Netsurf (2.8 and latest dev build) it works IF I use http://192.168.0.1/nckc/login.php
but fails for http://laptop2/nckc/login.php
There is a cookie created in 192.168.0.1 called PHPSESSID. There is nothing created when connecting to the laptop by name. (I deleted all the cookies first, so I could be sure.)
I noticed a bug reporting this in 2007, closed without any comment I could find, except "expired".
I am new to writing PHP, so the problem could be in my code, which was cribbed in the usual fashion from google.
Alan Adams
Additional Informationnobody added a note on Sun Jan 22 21:18:51 2012

previous comment should have started http://laptop2/nckc i.e. the host name contains no dots. Sorry for any confusion.

nobody added a note on Sun Jan 22 21:16:57 2012

I set up a DNS server, so http://laptop2.nckc/index.php became http://laptop2.adamshome.local/nck/index.php and the problem was no longer seen.

nobody added a note on Thu Jan 19 22:11:57 2012

I am guessing that this occurs when the domain name doesn't contain a dot.

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3475082 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000072

Vincent Sanders (administrator)

cookie handling still needs an overhaul
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-18 18:03 Vincent Sanders Note Added: 0000072
2013-12-18 18:03 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-18 18:03 Vincent Sanders Status assigned => acknowledged
2013-12-18 18:03 Vincent Sanders Resolution no change required => open
2013-12-18 18:03 Vincent Sanders Description Updated View Revisions
2013-12-18 18:03 Vincent Sanders Additional Information Updated View Revisions
+Issue History