2019-12-07 00:21 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000463NetSurfRISC OS-specificpublic2015-10-31 16:58
ReporterTony Moore 
Assigned To 
SeverityminorReproducibilityalways 
StatusconfirmedResolutionopen 
Product Version2.0 
Target VersionFixed in Version 
Summary0000463: 'new-look' Register: full-save fails
DescriptionNetSurf 2.0 (Dev) (11 Sep 2008 21:45) r5304

When any 'new-look' Register news-page (eg http://www.theregister.co.uk/2008/09/17/reiss_leaves_rs/ ) is full-saved, the file version of the page does not display correctly.

This occurs because the source html of the page contains
<link rel="stylesheet" type="text/css" href="http://www.theregister.co.uk/style_picker/design"> which NetSurf fails to convert into a local link, although the css file 'style_picker/design' _is_ saved as '36d177d8', or whatever.

Tony



Additional Informationold_coaster added a note on Thu Sep 18 15:53:03 2008

To see the problem, using r5369:

1 full-save any news page from the Register,
2 take the computer off-line,
3 load the file copy of the Register page.

You will find that the formatting of the file copy page is bizarre.

Step 2, above, is necessary to prevent NetSurf loading the CSS file from the net (in the file copy html, the link to the CSS file still points to the net, instead of the file copy of the CSS file).

Tony





nobody added a note on Thu Sep 18 11:43:03 2008

I cannot reproduce this problem (r5369).

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=2116103 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #3021
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Tony Moore

~0000194

Tony Moore (reporter)

Checked with NS 1700 jsoff and
http://www.theregister.co.uk/2014/02/07/snowden_documents_show_british_digital_spies_using_viruses_and_honey_traps/
The problem is still reproducible, as described in 'Additional information' above. I should add that it's also necessary to clear the NS cache, to avoid loading a local copy of the CSS file.

Tony
David Pitt

~0000780

David Pitt (reporter)

Last edited: 2015-03-16 11:53

View 2 revisions

This bug is still present, tested with NerSurf 3.4 0002652

http://www.theregister.co.uk/2008/09/17/reiss_leaves_rs/

The HTML contains :-

 <LINK rel="stylesheet" type="text/css" href="http://www.theregister.co.uk/style_picker/design?j">

The saved css appears to be unused.

Dave Higton

~0000985

Dave Higton (developer)

Still present in CI#3021.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-24 13:53 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-24 13:53 Vincent Sanders Status assigned => acknowledged
2013-12-24 13:53 Vincent Sanders Resolution no change required => open
2013-12-24 13:53 Vincent Sanders Category General => RISC OS-specific
2013-12-24 13:53 Vincent Sanders Product Version => 2.0
2013-12-24 13:53 Vincent Sanders Summary 'new-look' Register: full-save fails => 'new-look' Register: full-save fails
2013-12-24 13:53 Vincent Sanders Description Updated View Revisions
2013-12-24 13:53 Vincent Sanders Additional Information Updated View Revisions
2014-02-09 13:31 Tony Moore Note Added: 0000194
2015-03-16 11:49 David Pitt Note Added: 0000780
2015-03-16 11:53 David Pitt Note Edited: 0000780 View Revisions
2015-10-29 22:03 Dave Higton Note Added: 0000985
2015-10-30 14:27 Vincent Sanders Status acknowledged => confirmed
2015-10-31 16:58 Vincent Sanders Reported in CI build # => 3021
2015-10-31 16:58 Vincent Sanders Reproducibility have not tried => always
+Issue History