2019-03-22 07:12 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000446NetSurfRISC OS-specificpublic2015-03-10 10:38
Reportermittens 
Assigned ToVincent Sanders 
SeverityminorReproducibilityhave not tried 
StatusclosedResolutionfixed 
PlatformStrongARM Risc PCOSRISC OSOS Version6
Product Version 
Target VersionFixed in Version3.1 
Summary0000446: "Failed creating formpost data" - hard spaces in file paths
DescriptionNetSurf consistently reports the error "Failed creating formpost data" when I submit the contents of a web form that has an input field of type "file" that contains a RISC OS file path with one or more hard-space characters. This is easy to work around once you realise what the problem is, but can be frustrating before then because the other contents of the form is lost on every attempt.

I have witnessed this problem with both the 09 Jan 2007 19:45 and 14 Jan 2007 13:15 test builds of NetSurf. I am using the RISC OS 6 preview (21 Nov 2006) on a StrongARM Risc PC.
Additional Informationjmb202 added a note on Thu Jan 18 02:09:48 2007

This may well be tangentially related to #1403338. It's clearly a charset issue.

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1635844 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #1582
Reported in CI build #
URL of problem page
Attached Files
  • txt file icon £47.txt (21 bytes) 2014-01-04 21:57 -
    This is a test file.
    
    txt file icon £47.txt (21 bytes) 2014-01-04 21:57 +

-Relationships
duplicate of 0002052closedChris Young Uploading files with non-ASCII filenames fails 
+Relationships

-Notes
Vincent Sanders

~0000662

Vincent Sanders (administrator)

Confirmed fixed in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-24 15:14 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-24 15:14 Vincent Sanders Status assigned => acknowledged
2013-12-24 15:14 Vincent Sanders Category General => RISC OS-specific
2013-12-24 15:14 Vincent Sanders OS => RISC OS
2013-12-24 15:14 Vincent Sanders OS Version => 6
2013-12-24 15:14 Vincent Sanders Platform => StrongARM Risc PC
2013-12-24 15:14 Vincent Sanders Description Updated View Revisions
2013-12-24 15:14 Vincent Sanders Additional Information Updated View Revisions
2014-01-04 19:18 Vincent Sanders Relationship added duplicate of 0002052
2014-01-04 21:57 Michael Drake File Added: £47.txt
2014-01-04 21:58 Michael Drake Fixed in CI build # => 1582
2014-01-04 21:58 Michael Drake Status acknowledged => resolved
2014-01-04 21:58 Michael Drake Resolution open => fixed
2014-01-04 21:58 Michael Drake Fixed in Version => 3.1
2014-01-04 21:58 Michael Drake Description Updated View Revisions
2014-01-04 21:58 Michael Drake Additional Information Updated View Revisions
2015-03-10 10:38 Vincent Sanders Note Added: 0000662
2015-03-10 10:38 Vincent Sanders Status resolved => closed
2015-03-10 10:38 Vincent Sanders Assigned To => Vincent Sanders
+Issue History