2019-04-22 16:03 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000430NetSurfLayoutpublic2015-03-02 16:16
Reportermoe85 
Assigned To 
SeverityminorReproducibilityalways 
StatusconfirmedResolutionopen 
PlatformRaspberry PIOSRISC OSOS Version5.19
Product Version3.0 
Target VersionFixed in Version 
Summary0000430: Text selection issues
DescriptionI'm having a hard time selecting text with the mouse. Maybe it's me, maybe not. If you see this as a Feature Request please move it.

To select some text I have to click and then drag the mouse in any direction.
-> This only works I the mouse cursor is inside a text and not above a hyperlink.

a) If the mouse is above a hyperlink and I press the mouse button the link is immediately opened (this is unusual in other browsers but seems acceptable.)

b) If the mouse cursor is not inside a text at all (eg. at the end / beginning) NetSurf simply won't start selecting anything.
Instead it will start dragging / scrolling the page around.

That way you cannot copy an email address that stands for alone or select a complete text from begin->end or other way round.
You can see it by trying to select the Word "NetSurf" in the upper left corner. I've also attached a very simple example.

Double clicking a word normally selects it up to an including the next space character. This does not work in NetSurf.
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3597584 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #0746
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000063

Vincent Sanders (administrator)

Text selection has been improved with the RISC OS frontend since you reported this issue. Can you try with a current CI build and see if the problem is reproducible?
Vincent Sanders

~0000233

Vincent Sanders (administrator)

No feedback from reporter, although I am assigning this if its not reproducible please feel free to close as such
Michael Drake

~0000624

Michael Drake (administrator)

HTML text selection is a bit dodgy. Won't be touched until the layout engine is rewritten.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-10 17:41 Vincent Sanders Description Updated View Revisions
2013-12-18 16:18 Vincent Sanders Reported in CI build # => 0746
2013-12-18 16:18 Vincent Sanders Note Added: 0000063
2013-12-18 16:18 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-18 16:18 Vincent Sanders Status assigned => feedback
2013-12-18 16:18 Vincent Sanders Resolution no change required => open
2013-12-18 16:18 Vincent Sanders Category General => RISC OS-specific
2013-12-18 16:18 Vincent Sanders OS => RISC OS
2013-12-18 16:18 Vincent Sanders OS Version => 5.19
2013-12-18 16:18 Vincent Sanders Platform => Raspberry PI
2013-12-18 16:18 Vincent Sanders Product Version => 3.0
2013-12-18 16:18 Vincent Sanders Description Updated View Revisions
2013-12-18 16:18 Vincent Sanders Additional Information Updated View Revisions
2014-02-10 10:43 Vincent Sanders Note Added: 0000233
2014-02-10 10:43 Vincent Sanders Assigned To => Michael Drake
2014-02-10 10:45 Vincent Sanders Assigned To Michael Drake => Steve Fryatt
2015-03-02 16:16 Michael Drake Note Added: 0000624
2015-03-02 16:16 Michael Drake Assigned To Steve Fryatt =>
2015-03-02 16:16 Michael Drake Reproducibility have not tried => always
2015-03-02 16:16 Michael Drake Status feedback => confirmed
2015-03-02 16:16 Michael Drake Category RISC OS-specific => Layout
2015-03-02 16:16 Michael Drake Summary Text selection issues on RISCOS => Text selection issues
+Issue History