2020-03-29 20:42 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002726NetSurfGTK-specificpublic2020-02-21 09:53
Reportergengreen 
Assigned To 
SeveritytrivialReproducibilityalways 
StatusclosedResolutionunable to reproduce 
PlatformPCOSLinuxOS VersionGentoo
Product Version 
Target VersionFixed in Version 
Summary0002726: CTRL + A on search input bar
Descriptionctrl + a on the search input select the whole page instead of the input content.

the shortcut work fine with the url bar, but with the search bar, it select all the content of the page
Additional InformationM.CONFIG: JPEG (libjpeg) enabled (NETSURF_USE_JPEG := YES)
M.CONFIG: PDF export (haru) disabled (NETSURF_USE_HARU_PDF := NO)
M.CONFIG: glibc internal iconv enabled (NETSURF_USE_LIBICONV_PLUG := YES)
M.CONFIG: Javascript (Duktape) disabled (NETSURF_USE_DUKTAPE := NO)
PKG.CNFG: CSS (libcss) enabled
PKG.CNFG: DOM (libdom) enabled
PKG.CNFG: nsutils (libnsutils) enabled
PKG.CNFG: utf8proc (libutf8proc) enabled
M.CONFIG: Curl (libcurl) enabled (NETSURF_USE_CURL := YES)
M.CONFIG: OpenSSL (openssl) enabled (NETSURF_USE_OPENSSL := YES)
M.CONFIG: WEBP (libwebp) enabled (NETSURF_USE_WEBP := YES)
M.CONFIG: PNG (libpng) enabled (NETSURF_USE_PNG := YES)
M.CONFIG: BMP (libnsbmp) enabled (NETSURF_USE_BMP := YES)
M.CONFIG: GIF (libnsgif) enabled (NETSURF_USE_GIF := YES)
M.CONFIG: SVG (libsvgtiny) enabled (NETSURF_USE_NSSVG := YES)
M.CONFIG: Sprite (librosprite) disabled (NETSURF_USE_ROSPRITE := NO)
M.CONFIG: PSL (libnspsl) disabled (NETSURF_USE_NSPSL := NO)
M.CONFIG: LOG (libnslog) auto-disabled (NETSURF_USE_NSLOG := AUTO)
M.CONFIG: SVG (librsvg-2.0) disabled (NETSURF_USE_RSVG := NO)
M.CONFIG: Video (gstreamer-0.10) disabled (NETSURF_USE_VIDEO := NO)
PKG.CNFG: GTK-3 (gtk+-3.0) enabled
PKG.CNFG: GThread2 (gthread-2.0) enabled
PKG.CNFG: GModule2 (gmodule-2.0) enabled
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Samuel Darden

~0002157

Samuel Darden (reporter)

https://google.com/
Michael Drake

~0002166

Michael Drake (administrator)

Unable to reproduce with current master. (GTK3 front end.)
+Notes

-Issue History
Date Modified Username Field Change
2019-12-08 09:27 gengreen New Issue
2020-01-03 03:28 Samuel Darden Note Added: 0002157
2020-02-21 09:47 Michael Drake Status new => resolved
2020-02-21 09:47 Michael Drake Resolution open => unable to reproduce
2020-02-21 09:47 Michael Drake Description Updated View Revisions
2020-02-21 09:47 Michael Drake Additional Information Updated View Revisions
2020-02-21 09:47 Michael Drake Note Added: 0002166
2020-02-21 09:53 Michael Drake Status resolved => closed
+Issue History