2020-09-22 07:15 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002693NetSurfABENDpublic2020-05-27 09:19
ReporterDave Higton 
Assigned ToVincent Sanders 
SeveritymajorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformBeagleBoard-xMOSRISC OSOS Version5.27 (21-Jul-19)
Product Version3.10 
Target VersionFixed in Version3.10 
Summary0002693: Mailto link causes instant crash
DescriptionClick on (apparently) any mailto link, and NS instantly crashes.
Steps To ReproduceClick on a mailto link.

I've uploaded a minimal HTML file with a mailto link as a demo.
TagsNo tags attached.
Fixed in CI build #4824
Reported in CI build #4823
URL of problem page
Attached Files
  • ? file icon Mailto (275 bytes) 2019-08-11 14:56 -
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
       <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
       <title>Test mailto</title>
    </head>
    <body>
    
    <a href="mailto:fred@bloggs.com">Email me</a>
    
    </body>
    </html>
    
    ? file icon Mailto (275 bytes) 2019-08-11 14:56 +
  • ? file icon crashdump (7,527 bytes) 2019-08-11 14:59 -
    ? file icon crashdump (7,527 bytes) 2019-08-11 14:59 +

-Relationships
+Relationships

-Notes
Dave Higton

~0002073

Dave Higton (developer)

The problem was originally pointed out by Peter Young in a newsgroup posting, so although I reported it here, it's in a confirmatory sense.
Vincent Sanders

~0002076

Vincent Sanders (administrator)

missing checks for internal navigation.
Fixed, thanks for the report
Vincent Sanders

~0002247

Vincent Sanders (administrator)

Thankyou for reporting this issue.
We believe this is fixed in the 3.10 release.
If this is not the case please feel free to reopen the issue with additional details.
+Notes

-Issue History
Date Modified Username Field Change
2019-08-11 14:56 Dave Higton New Issue
2019-08-11 14:56 Dave Higton File Added: Mailto
2019-08-11 14:59 Dave Higton File Added: crashdump
2019-08-11 20:47 Dave Higton Status new => confirmed
2019-08-11 20:47 Dave Higton Note Added: 0002073
2019-08-12 12:58 Vincent Sanders Assigned To => Vincent Sanders
2019-08-12 12:58 Vincent Sanders Status confirmed => resolved
2019-08-12 12:58 Vincent Sanders Resolution open => fixed
2019-08-12 12:58 Vincent Sanders Product Version => 3.10
2019-08-12 12:58 Vincent Sanders Fixed in Version => 3.10
2019-08-12 12:58 Vincent Sanders Steps to Reproduce Updated View Revisions
2019-08-12 12:58 Vincent Sanders Fixed in CI build # => 4824
2019-08-12 12:58 Vincent Sanders Note Added: 0002076
2020-05-27 09:19 Vincent Sanders Status resolved => closed
2020-05-27 09:19 Vincent Sanders Note Added: 0002247
+Issue History