2019-12-15 12:00 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002654NetSurf[All Projects] Generalpublic2019-05-24 10:11
ReporterMark 
Assigned To 
SeveritymajorReproducibilityalways 
StatusacknowledgedResolutionopen 
Product Version3.8 
Target VersionFixed in Version 
Summary0002654: Warning from Netsurf - Couldn't use specified SSL cipher
DescriptionHello!

I am a user of Centos 7. I built Netsurf 3.9 from source following the instructions on https://source.netsurf-browser.org/netsurf.git/plain/docs/quick-start.md. When I try to use it to go to a secure site, for example https://bugs.netsurf-browser.org/, I get a pop-up window that says, "Warning from Netsurf - Couldn't use specified SSL cipher." This stops me from going to the secure site.
Steps To ReproduceBuild Netsurf 3.9 on Centos 7 using the instructions on https://source.netsurf-browser.org/netsurf.git/plain/docs/quick-start.md. Run Netsurf and try to open https://bugs.netsurf-browser.org/.
Additional InformationI though it might help to see the output from uname -a:
Linux solextel.com 3.10.0-957.12.2.el7.x86_64 #1 SMP Tue May 14 21:24:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I'm using a Dell PowerEdge T105 which is AMD based.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem pagehttps://bugs.netsurf-browser.org/
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0001918

Vincent Sanders (administrator)

This is a quick developer note for when the team comes back to triage bugs

seems centos 7 and rhel now use the nss ssl library by default instead of openssl and the NetSurf cipher suite selection for ssl needs to use a different list.

Yet another case of libcurl ssl abstraction being leaky.
+Notes

-Issue History
Date Modified Username Field Change
2019-05-22 22:10 Mark New Issue
2019-05-24 10:11 Vincent Sanders Status new => acknowledged
2019-05-24 10:11 Vincent Sanders Note Added: 0001918
+Issue History