2019-07-22 17:49 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002644NetSurfABENDpublic2019-07-19 09:21
ReporterRichard Porter 
Assigned ToDaniel Silverstone 
SeveritycrashReproducibilityunable to reproduce 
StatusclosedResolutionfixed 
PlatformARMX6OSRISC OSOS Version5.25
Product Version3.9 
Target VersionFixed in Version3.9 
Summary0002644: Segmentation Fault (booking.com)
DescriptionTrying to give feedback to giving.com. Page is in the zip file.
Only the textareas can be used so I used those.
On submitting the form NetSurf crashed with a segfault.
Steps To ReproduceEnter stuff in form, submit form.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #4630
URL of problem pagehttps://s.sg.booking.com/uni/mpss/c/GQE/0O0MAA/t.2rd/jSezk6NKTQyv_qQXk4vIOA/h1/h-2B7n1PrGbiWDunSuXdpxLXO0wAxoNiulxKnTrkw-2BpuYD3XzZlwljhYnN2taYn2rWoO2yyeqgUdvggxxYnajL3RSulqxXFYQ8d5kSry1il1othKnNoj8ZP5djHYe4cvx9B89nOqq7mztEV7qEjvOxygZVrkpxe5KZRFOkA-2FPH9Q
Attached Files
  • ? file icon nslog328 (107,484 bytes) 2019-05-07 11:30 -
    ? file icon nslog328 (107,484 bytes) 2019-05-07 11:30 +

-Relationships
+Relationships

-Notes
Vincent Sanders

~0001987

Vincent Sanders (administrator)

Daniel has improved the javascript callback handling a great deal (which is what crashed) and I cannot make the browser fail on booking.com so I believe this issue to be fixed.

Please feel free re-open the bug if this reoccurs
Vincent Sanders

~0001988

Vincent Sanders (administrator)

we believe this issue has been fixed in NetSurf 3.9
+Notes

-Issue History
Date Modified Username Field Change
2019-05-07 11:30 Richard Porter New Issue
2019-05-07 11:30 Richard Porter File Added: nslog328
2019-07-15 11:18 Vincent Sanders Assigned To => Daniel Silverstone
2019-07-15 11:18 Vincent Sanders Reproducibility always => unable to reproduce
2019-07-15 11:18 Vincent Sanders Status new => resolved
2019-07-15 11:18 Vincent Sanders Resolution open => fixed
2019-07-15 11:18 Vincent Sanders Product Version => 3.9
2019-07-15 11:18 Vincent Sanders Fixed in Version => 3.9
2019-07-15 11:18 Vincent Sanders Description Updated View Revisions
2019-07-15 11:18 Vincent Sanders Note Added: 0001987
2019-07-19 09:21 Vincent Sanders Status resolved => closed
2019-07-19 09:21 Vincent Sanders Note Added: 0001988
+Issue History