2018-12-10 07:21 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002627NetSurfGTK-specificpublic2018-11-03 11:26
Reporterq3cpma 
Assigned To 
SeverityminorReproducibilityunable to reproduce 
StatusclosedResolutionno change required 
PlatformGNU/LinuxOSGentooOS Version2.4.1
Product Version3.8 
Target VersionFixed in Version 
Summary0002627: Build of all tarball fails with `No rule to make target 'default.css', needed by 'build/Linux-gtk/netsurf_gresource.c'`
DescriptionTrying to build netsurf from the tarball containing everything, I get the error:

MSGSPLIT: Language: fr Filter: gtk
make[1]: *** No rule to make target 'default.css', needed by 'build/Linux-gtk/netsurf_gresource.c'. Stop.
make[1]: *** Waiting for unfinished jobs....


I'm trying to build it this way since Gentoo is stuck on 3.6 (and the package maintainer is non responsive).
Steps To ReproduceThe exact command used was:

CFLAGS="-O3 -march=native -pipe" make -j8 >build.log 2>&1

But a simple make -j1 produced the same error.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0001856

Vincent Sanders (administrator)

This is caused by the tool glib-compile-resources being unable to find the resource files it requires.

default.css is a symbolic link from frontends/res/default.css to resources/default.css

it appears that in the sources you have unpacked teh default.css symbolic link is not working. We verified the source tarball downloaded from the netsurf website does unpack and build correctly.

$ ls -al frontends/gtk/res/default.css
lrwxrwxrwx 1 vince vince 30 Aug 29 11:32 frontends/gtk/res/default.css -> ../../../resources/default.css
$ ls -al resources/default.css
-rw-r--r-- 1 vince vince 5181 Aug 29 11:32 resources/default.css

Unfortunately the resource compilation tool does not generate errors or valid dependency filenames if a resource cannot be located so there is no way to detect or fix this error in the makefile
Daniel Silverstone

~0001857

Daniel Silverstone (administrator)

Hi q3cpma,

From the looks of your build log, and some rummaging that Vincent and myself did last night, it looks as though the symbolic links in the tarball are not working.

It's not uncommon for `Downloads` directories to be mounted "interestingly" to prevent things like symbolic links.

Could you please confirm that:

(a) your filesystem supports symbolic links
(b) they're not prevented in/under your Downloads directory
(c) the link at netsurf-all-3.8/netsurf/frontends/gtk/res/defaults.css is present
(d) that the link is correct (../../../resources/defaults.css)

If any of the above fail, then you could try unpacking the tarball elsewhere on your system to build it. If all of the above is OK then we'll have to think again.

Thank you,

Daniel.
q3cpma

~0001858

q3cpma (reporter)

Sorry, this was my fault, it looks like pax has a bug where the -s options acts on symlink targets rather than names.
Vincent Sanders

~0001859

Vincent Sanders (administrator)

thankyou for the feedback, closing the bug
+Notes

-Issue History
Date Modified Username Field Change
2018-10-21 13:52 q3cpma New Issue
2018-10-21 13:52 q3cpma File Added: build.log
2018-10-23 19:30 Vincent Sanders Status new => acknowledged
2018-10-23 19:30 Vincent Sanders Category General => GTK-specific
2018-11-03 08:43 Vincent Sanders Note Added: 0001856
2018-11-03 08:43 Vincent Sanders Reproducibility always => unable to reproduce
2018-11-03 08:43 Vincent Sanders Status acknowledged => closed
2018-11-03 08:43 Vincent Sanders Resolution open => unable to reproduce
2018-11-03 08:44 Daniel Silverstone Note Added: 0001857
2018-11-03 10:11 q3cpma Status closed => feedback
2018-11-03 10:11 q3cpma Resolution unable to reproduce => reopened
2018-11-03 10:11 q3cpma Note Added: 0001858
2018-11-03 11:26 Vincent Sanders Status feedback => closed
2018-11-03 11:26 Vincent Sanders Resolution reopened => no change required
2018-11-03 11:26 Vincent Sanders Note Added: 0001859
+Issue History