2018-10-23 06:55 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002582NetSurfAmiga-specificpublic2018-08-29 15:05
ReporterChris Young 
Assigned ToChris Young 
SeverityblockReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.8 
Target Version3.8Fixed in Version3.8 
Summary0002582: NetSurf won't launch on SAM440EP since OpenSSL 1.1
DescriptionNetSurf crashes shortly after the splash screen appears. See attached logs.
Additional InformationThe command-line "openssl" appears to be working, as does "curl".
TagsNo tags attached.
Fixed in CI build #4260
Reported in CI build #4250
URL of problem pagehttps://www.howsmyssl.com
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001693

Chris Young (developer)

Trying to ascertain if the OS4 problem only affects the PPC 440EP or other CPUs too.
Chris Young

~0001695

Chris Young (developer)

Had a report that the latest build is working on the X1000.
Chris Young

~0001696

Chris Young (developer)

Seems to be working on X1000 and X5000 but not on anything else.
The current link seems to be the working ones use the PPC_FPU64 setting, and the non-working ones don't. OpenSSL itself appears to be working OK, but it's throwing something out in NetSurf (either trashing memory, or causing alignment issues).
Chris Young

~0001697

Chris Young (developer)

DOSBase was either getting trashed or for some reason not available as it had been before. Explicitly opening the library seems to resolve the issue.
Vincent Sanders

~0001842

Vincent Sanders (administrator)

Thank you for your report, this has been resolved in the 3.8 release
+Notes

-Issue History
Date Modified Username Field Change
2017-12-10 16:54 Chris Young New Issue
2017-12-10 16:54 Chris Young Status new => assigned
2017-12-10 16:54 Chris Young Assigned To => Chris Young
2017-12-10 16:54 Chris Young Status assigned => confirmed
2017-12-10 16:54 Chris Young Note Added: 0001693
2017-12-10 16:55 Chris Young File Added: ns.log
2017-12-10 16:55 Chris Young File Added: Crashlog_NetSurf_2017-12-10_15-46-49.txt
2017-12-10 16:57 Chris Young Additional Information Updated View Revisions
2017-12-10 17:16 Chris Young Relationship added related to 0002583
2017-12-10 17:17 Chris Young Summary SSL not working on Amiga builds => NetSurf won't launch on SAM440EP since OpenSSL 1.1
2017-12-10 17:17 Chris Young Description Updated View Revisions
2017-12-10 17:17 Chris Young Additional Information Updated View Revisions
2017-12-10 17:21 Chris Young Note Added: 0001695
2017-12-10 21:20 Chris Young Note Added: 0001696
2017-12-10 23:23 Chris Young Status confirmed => resolved
2017-12-10 23:23 Chris Young Resolution open => fixed
2017-12-10 23:23 Chris Young Fixed in Version => 3.8
2017-12-10 23:23 Chris Young Fixed in CI build # => 4260
2017-12-10 23:23 Chris Young Note Added: 0001697
2017-12-10 23:24 Chris Young Relationship deleted related to 0002583
2018-08-29 15:05 Vincent Sanders Status resolved => closed
2018-08-29 15:05 Vincent Sanders Note Added: 0001842
+Issue History