2019-06-24 23:15 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002556NetSurfABENDpublic2017-10-16 23:35
ReporterRichard Porter 
Assigned To 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformARMX6OSRISC OSOS Version5.23
Product Version 
Target VersionFixed in Version3.7 
Summary0002556: Seg Fault on Flickr
DescriptionSee 2550. I'm rereporting this fault as it is still 100% repeatable.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #4140
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
agrecascino

~0001602

agrecascino (reporter)

I'm not getting a crash on Linux(Slackware 14.2, x64), if that's any use.
Richard Porter

~0001603

Richard Porter (reporter)

NB I have 1.9GB of free memory.
Dave Higton

~0001610

Dave Higton (developer)

What URL causes it for you, Richard? I just tried flickr.com on a BBxM and version 4213, and there was no crash.
Dave Higton

~0001619

Dave Higton (developer)

My apologies, the URL is given in the original Mantis report, 2550.

But I've tried it on a BBxM with NS 4213 and RO 5.23 (08-Sep-17), and it doesn't crash, so I cannot reproduce the problem.

(I agree there are serious layout issues, but they should be the subject of a different report.)

What can be different between Richard's system and mine? His is an ARMX6, which is a different ARM version. Are we certain that all of the build process produces code for that ARM version?

Otherwise, is there some other app trampling on NS's memory?
Richard Porter

~0001621

Richard Porter (reporter)

I'm now running #4213 and it's not crashing, so I think you can close the report.
Dave Higton

~0001623

Dave Higton (developer)

Closed as resolved, per the original reporter's new note.
Vincent Sanders

~0001646

Vincent Sanders (administrator)

Thankyou for your report, this has been resolved in the 3.7 release
+Notes

-Issue History
Date Modified Username Field Change
2017-09-12 11:05 Richard Porter New Issue
2017-09-13 06:05 agrecascino Note Added: 0001602
2017-09-13 10:40 Richard Porter Note Added: 0001603
2017-10-02 21:15 Dave Higton Note Added: 0001610
2017-10-03 12:14 Dave Higton Note Added: 0001619
2017-10-03 12:30 Richard Porter Note Added: 0001621
2017-10-03 13:49 Dave Higton Status new => resolved
2017-10-03 13:49 Dave Higton Resolution open => fixed
2017-10-03 13:49 Dave Higton Fixed in Version => 3.7
2017-10-03 13:49 Dave Higton Note Added: 0001623
2017-10-16 23:35 Vincent Sanders Status resolved => closed
2017-10-16 23:35 Vincent Sanders Note Added: 0001646
+Issue History