2019-01-23 01:51 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002440NetSurfAmiga-specificpublic2016-11-22 22:00
ReporterChris Young 
Assigned ToChris Young 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.4 
Target VersionFixed in Version3.6 
Summary0002440: Non-ASCII chars in hotlist entry titles get converted to '?'
DescriptionNon-ASCII chars in hotlist entry titles get converted to '?' when the hotlist is exported/saved.
Steps To ReproduceVisit http://news.google.ru
Add it to the Hotlist
Observe the title in the hotlist is correct.
Either export the hotlist and load it into NetSurf, or quit NetSurf and re-load in order to save and re-load the hotlist into memory.
Observe that the title in the hotlist is now "??????? Google" (with all the Cyrillic chars replaced by question marks)
Additional Informationutf8_to_html() does not appear to be doing what it is supposed to on OS4.
TagsNo tags attached.
Fixed in CI build #3579
Reported in CI build #4344
URL of problem pagehttp://news.google.ru
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001343

Chris Young (developer)

With LIBICONV_PLUG=YES (which is our default), both the window title and the exported hotlist replace the non-ASCII characters with question marks.
Toggling LIBICONV_PLUG=NO, the non-ASCII characters fail to convert at all in the window title, however the exported hotlist file is correct.
Chris Young

~0001381

Chris Young (developer)

Fixed in CI#3579
Switched to using libiconv and fixed the residual issues.
Vincent Sanders

~0001433

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2016-03-06 00:41 Chris Young New Issue
2016-03-06 00:41 Chris Young Status new => assigned
2016-03-06 00:41 Chris Young Assigned To => Chris Young
2016-03-06 00:45 Chris Young Note Added: 0001343
2016-03-06 00:45 Chris Young Status assigned => confirmed
2016-06-25 21:19 Chris Young Fixed in CI build # => 3579
2016-06-25 21:19 Chris Young Note Added: 0001381
2016-06-25 21:19 Chris Young Status confirmed => resolved
2016-06-25 21:19 Chris Young Fixed in Version => 3.6
2016-06-25 21:19 Chris Young Resolution open => fixed
2016-11-22 22:00 Vincent Sanders Note Added: 0001433
2016-11-22 22:00 Vincent Sanders Status resolved => closed
+Issue History