2019-03-26 21:21 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002390NetSurfAmiga-specificpublic2016-02-16 14:09
ReporterSamir Hawamdeh 
Assigned ToChris Young 
SeveritycrashReproducibilityrandom 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.3 
Target VersionFixed in Version3.4 
Summary0002390: Crash in clipboard.device (copy and paste)
DescriptionFound a bug in NetSurf-3.3055 nightly, i had a session when i did some spare copy and paste using the contextmenu .. no crash when i play with them however when i close NetSurf i got this one:


Crash log for task "NetSurf"
Generated by GrimReaper 53.19
Crash occured in module clipboard.device at address 0x6D48C8BC
Type of crash: DSI (Data Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):
0: 0181B9E4 58614EA0 00000000 533092D4 53309328 541F9350 000000D0 02014564
8: 01947B6C 00000008 541F941C 021CDCC2 020B9CE4 510B31C8 00000000 53EA8680
16: 58615000 00000000 58615008 00000000 58615004 42E27190 8000001E 58A35CA0
24: 510B0000 00000000 6FE38A0C 4A1C4820 510B0000 510B0000 020B9CE4 00240080


FPR (Floating Point Registers, NaN = Not a Number):
0: nan 866 736 0
4: 36 127.8 53.8 2.14748e+09
8: 18 128 1 nan
12: 1 754 3.39519e-313 -0
16: 0 0 0 0
20: 0 0 0 1.61895e-319
24: 0 0 0 -1.28745e+36
28: 0 1.35808e-312 1.3581e-312 -3.40282e+38

FPSCR (Floating Point Status and Control Register): 0xA2004100


SPRs (Special Purpose Registers):
Machine State (msr) : 0x0002F030
Condition (cr) : 0x42763D80
Instruction Pointer (ip) : 0x6D48C8BC
Xtended Exception (xer) : 0x018193D0
Count (ctr) : 0x427640F8
Link (lr) : 0x0002000E
DSI Status (dsisr) : 0x41827E1C
Data Address (dar) : 0x427640F8



680x0 emulated registers:
DATA: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x6D48C8BC belongs to module "clipboard.device" (HUNK/Kickstart)

Stack trace:
module DEVS:clipboard.device at 0x6D48C8BC (section 4 @ 0x898)
native kernel module kernel+0x0001b9e4
native kernel module ramlib.kmod+0x0000150c
module LIBS:iffparse.library at 0x6FFB927C (section 5 @ 0x2258)
ami_clipboard_free()+0x70 (section 1 @ 0x3F10)
[amiga/gui.c:2941] gui_quit()+0x100 (section 1 @ 0x127CC)
[desktop/netsurf.c:244] netsurf_exit()+0x3c (section 1 @ 0x121518)
[amiga/gui.c:5466] main()+0xad4 (section 1 @ 0x1FBBC)
native kernel module newlib.library.kmod+0x000020ac
native kernel module newlib.library.kmod+0x00002d5c
native kernel module newlib.library.kmod+0x00002ef0
_start()+0x170 (section 1 @ 0x16C)
native kernel module dos.library.kmod+0x00024c18
native kernel module kernel+0x0003b648
native kernel module kernel+0x0003b6c8

PPC disassembly:
6d48c8b4: 83e30010 lwz r31,16(r3)
6d48c8b8: 93a10014 stw r29,20(r1)
*6d48c8bc: a01f0020 lhz r0,32(r31)
6d48c8c0: 83df0074 lwz r30,116(r31)
6d48c8c4: 2f800000 cmpwi cr7,r0,0

System information:

CPU
Model: AMCC PPC440EP V1.3
CPU speed: 799 MHz
FSB speed: 133 MHz
Extensions:

Machine
Machine name: Sam440EP
Memory: 1048576 KB
Extensions: bus.pci
TagsNo tags attached.
Fixed in CI build #3332
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001087

Chris Young (developer)

This occurs randomly (but rarely), it doesn't appear to matter if the clipboard was used or not so I suspect memory is getting trashed somewhere.
Chris Young

~0001098

Chris Young (developer)

It looks like memory is getting trashed on exit, as if I launch and quit NetSurf tens of times I get other weird effects. MemGuard does not appear to work any more and the debug kernel is not translating this into a crash, which will make it tricky to track down.
Chris Young

~0001166

Chris Young (developer)

I believe this is fixed, I'm no longer able to reproduce it.
Vincent Sanders

~0001241

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-11-13 08:59 Samir Hawamdeh New Issue
2015-11-13 12:48 Chris Young Assigned To => Chris Young
2015-11-13 12:48 Chris Young Status new => assigned
2015-11-13 12:50 Chris Young Note Added: 0001087
2015-11-13 12:50 Chris Young Status assigned => confirmed
2015-11-16 20:59 Chris Young Note Added: 0001098
2016-01-31 18:34 Chris Young Fixed in CI build # => 3332
2016-01-31 18:34 Chris Young Note Added: 0001166
2016-01-31 18:34 Chris Young Status confirmed => resolved
2016-01-31 18:34 Chris Young Fixed in Version => 3.4
2016-01-31 18:34 Chris Young Resolution open => fixed
2016-02-16 14:09 Vincent Sanders Note Added: 0001241
2016-02-16 14:09 Vincent Sanders Status resolved => closed
+Issue History