2019-06-25 03:26 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002386NetSurf[All Projects] Generalpublic2016-11-22 21:59
ReporterAnthony J. Bentley 
Assigned ToVincent Sanders 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0002386: Pass BMP suite
DescriptionThere's a BMP testsuite, written by Jason Summers, available here: http://entropymine.com/jason/bmpsuite/

It provides a number of testcases, intentionally constructed to exercise a BMP decoder. Nearly every colored image fails in exactly the same way—the rightmost and leftmost columns are swapped. This seems to indicate some sort of bug in palettes?

You can easily view all images in NetSurf here:
http://entropymine.com/jason/bmpsuite/bmpsuite/html/bmpsuite.html
TagsNo tags attached.
Fixed in CI build #3664
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001086

Chris Young (developer)

What OS and hardware are you using?

I had a quick look here and I can't see the problem you describe, so I suspect it's an endian issue in libnsbmp, or NetSurf frontend issue (which could also be endian-related).

I am however getting a severe layout problem, where the column containing the BMP images is excessively wide, and the table is excessively tall. This is likely caused by one of the BMP images having a misinterpreted size. I'd be interested to know if you're getting this too.
Vincent Sanders

~0001388

Vincent Sanders (administrator)

This was an error in the bmp completion callback which caused gtk image fixup not to happen hence a messed up palette. Actually a bug in netsurf itself rather than the bmp library
Vincent Sanders

~0001430

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2015-11-09 08:58 Anthony J. Bentley New Issue
2015-11-13 00:38 Chris Young Note Added: 0001086
2016-08-15 00:00 Vincent Sanders Fixed in CI build # => 3664
2016-08-15 00:00 Vincent Sanders Note Added: 0001388
2016-08-15 00:00 Vincent Sanders Assigned To => Vincent Sanders
2016-08-15 00:00 Vincent Sanders Status new => assigned
2016-08-15 00:00 Vincent Sanders Resolution open => fixed
2016-08-15 00:01 Vincent Sanders Project LibNSBMP => NetSurf
2016-08-15 00:01 Vincent Sanders Status assigned => resolved
2016-08-15 00:01 Vincent Sanders Fixed in Version => 3.6
2016-11-22 21:59 Vincent Sanders Note Added: 0001430
2016-11-22 21:59 Vincent Sanders Status resolved => closed
+Issue History