2019-08-19 03:16 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002381NetSurfLayoutpublic2016-02-16 14:28
ReporterHarriet Bazley 
Assigned ToMichael Drake 
SeverityminorReproducibilityrandom 
StatusclosedResolutionfixed 
PlatformARMOSRISC OSOS Version5.19
Product Version3.4 
Target Version3.4Fixed in Version3.4 
Summary0002381: Crash after clicking to scroll
DescriptionI saw this a couple of days ago on http://www.fanfiction.net but haven't bothered to report it - now it's happened again when scrolling down a Gmail window. Almost certainly the result of some recent change, as I've never experienced scrollbar-related issues on any site before.

Netsurf occasionally crashes with a segfault when I click on the well of the scrollbar to scroll down. JavaScript was enabled at the time, and the log suggests that the crash is JS-related.
Steps To ReproduceNot reproduceable to order, unfortunately.
Additional InformationIyonix Aria, RISC OS 5.20

Snipped log (last thousand lines or so) attached.
TagsNo tags attached.
Fixed in CI build #3052
Reported in CI build #3046
URL of problem page
Attached Files
  • zip file icon snipped.zip (12,521 bytes) 2015-11-05 19:43
  • ? file icon Log_02 (18,014 bytes) 2015-11-05 20:55 -
    ? file icon Log_02 (18,014 bytes) 2015-11-05 20:55 +
  • ? file icon Log_03 (23,093 bytes) 2015-11-05 21:32 -
    ? file icon Log_03 (23,093 bytes) 2015-11-05 21:32 +

-Relationships
duplicate of 0002375closedMichael Drake Crashed on accidental click 
+Relationships

-Notes
Dave Higton

~0001030

Dave Higton (developer)

I managed to get a segfault while trying to reproduce the symptoms (Iyonix, RO 5.22, CI#3049). Log_02 attached, which shows:

fire_dom_event: Dispatching 'click' against 0x0

I couldn't see any scrollbars but the ordinary RISC OS ones, which seemed to work OK - Harriet, if there are any more details about how to get it to happen, please add them in a note.
Dave Higton

~0001031

Dave Higton (developer)

Last edited: 2015-11-05 21:43

View 2 revisions

Got the way to recreate it on fanfiction.net. Drag the horizontal scroll bar all the way over to the right. A beige area appears between the main window content and the vertical scroll bar. Click in that area and you guarantee a segfault.

The area of the same colour below the main content does not cause a segfault.

Log_03 is another log of the same.

Dave Higton

~0001032

Dave Higton (developer)

Last edited: 2015-11-05 22:25

View 3 revisions

It happens identically on the linux gtk version built from today's source.

My guess is that an area that shouldn't be sensitive to clicks, has been given (or left with) sensitivity.

Apart from fixing that problem - which you have to get right, every time, for every pixel of every page, no matter how the window size, scroll bars, etc. are dragged around - but you can also fix it by refusing to dispatch clicks agains null objects. Belt and braces suggests that both are desirable.

Vincent Sanders

~0001258

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-11-05 19:43 Harriet Bazley New Issue
2015-11-05 19:43 Harriet Bazley File Added: snipped.zip
2015-11-05 20:55 Dave Higton Note Added: 0001030
2015-11-05 20:55 Dave Higton File Added: Log_02
2015-11-05 21:03 Vincent Sanders Assigned To => Daniel Silverstone
2015-11-05 21:03 Vincent Sanders Status new => confirmed
2015-11-05 21:03 Vincent Sanders Category General => Javascript
2015-11-05 21:03 Vincent Sanders Product Version => 3.4
2015-11-05 21:03 Vincent Sanders Description Updated View Revisions
2015-11-05 21:03 Vincent Sanders Additional Information Updated View Revisions
2015-11-05 21:09 Vincent Sanders Relationship added duplicate of 0002375
2015-11-05 21:32 Dave Higton File Added: Log_03
2015-11-05 21:40 Dave Higton Note Added: 0001031
2015-11-05 21:42 Dave Higton Description Updated View Revisions
2015-11-05 21:42 Dave Higton Additional Information Updated View Revisions
2015-11-05 21:43 Dave Higton Note Edited: 0001031 View Revisions
2015-11-05 22:24 Dave Higton Note Added: 0001032
2015-11-05 22:24 Dave Higton Note Edited: 0001032 View Revisions
2015-11-05 22:25 Dave Higton Note Edited: 0001032 View Revisions
2015-11-06 14:48 Michael Drake Fixed in CI build # => 3052
2015-11-06 14:48 Michael Drake Assigned To Daniel Silverstone => Michael Drake
2015-11-06 14:48 Michael Drake Status confirmed => resolved
2015-11-06 14:48 Michael Drake Resolution open => fixed
2015-11-06 14:48 Michael Drake Category Javascript => Layout
2015-11-06 14:48 Michael Drake Fixed in Version => 3.4
2015-11-06 14:48 Michael Drake Target Version => 3.4
2015-11-06 14:48 Michael Drake Description Updated View Revisions
2015-11-06 14:48 Michael Drake Additional Information Updated View Revisions
2016-02-16 14:28 Vincent Sanders Note Added: 0001258
2016-02-16 14:28 Vincent Sanders Status resolved => closed
+Issue History