2019-01-23 01:42 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002364NetSurfJavascriptpublic2016-02-16 14:46
ReporterHarriet Bazley 
Assigned ToMichael Drake 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformARMOSRISC OSOS Version5.19
Product Version3.4 
Target VersionFixed in Version3.4 
Summary0002364: JavaScript-related lockup
DescriptionWith JavaScript enabled, attempting to view page https://www.fanfiction.net/stats/story_eyes.php when logged in to site causes desktop to lock up (pointer moves, nothing responds).


Steps To ReproduceUnfortunately I don't think this page can be accessed without a fanfiction.net account, but I can replicate the effect by trying to load a RISC OS 'full save' application back into the browser after a Netsurf quit and restart.
Simply running the saved HTML page alone with JavaScript enabled gives no problems.
(I don't actually understand this, since the saved app contains no scripts that I can see....)
Additional InformationZipped full save attached.

Iyonix Aria running RISC OS 5.20
TagsNo tags attached.
Fixed in CI build #3032
Reported in CI build #2998
URL of problem pagehttps://www.fanfiction.net/stats/story_eyes.php
Attached Files

-Relationships
duplicate of 0002366closedMichael Drake JS lockup 
+Relationships

-Notes
Dave Higton

~0000959

Dave Higton (developer)

I tried it just now, loading story_eyes.zip into #2999 with JS enabled. It isn't an infinite single-tasking loop, but it did take an extraordinarily long time to resume normal operation. But it did in the end return, and render a sensible-looking page.
Harriet Bazley

~0000962

Harriet Bazley (reporter)

I tried again with story_eyes.zip on version #3000 here, and after five minutes or so it still hadn't rendered. The log isn't very helpful as it simply appears to report that everything was fetched successfully: Log3.zip
Dave Higton

~0000963

Dave Higton (developer)

Harriet: I just tried it again on the Iyonix, and it single tasked for 9 minutes 51 seconds (CI#3000). Your machine must be similar.

For an interesting comparison, the BBxM under the same conditions was back well within 4 minutes. Most curious.
Harriet Bazley

~0000988

Harriet Bazley (reporter)

Raw processing power evidently counts...

Same behaviour turns out to affect ANY page on this site that displays the 'collapsible' menu entries, which is a bit of a killer if you accidentally try to reply to an e-mail PM notification, etc.
Vincent Sanders

~0000990

Vincent Sanders (administrator)

this is the same root cause as bug 2366 so we will update that
Dave Higton

~0001007

Dave Higton (developer)

Was about 4 minutes on BBxM with CI#3000, now down to 11 seconds under the same conditions with CI#3032.

Duplicate of 2366, now resolved.
Vincent Sanders

~0001279

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-10-14 13:43 Harriet Bazley New Issue
2015-10-14 13:43 Harriet Bazley File Added: story_eyes.zip
2015-10-17 21:00 Dave Higton Note Added: 0000959
2015-10-18 17:14 Harriet Bazley File Added: Log3.zip
2015-10-18 17:16 Harriet Bazley Note Added: 0000962
2015-10-18 19:42 Dave Higton Note Added: 0000963
2015-10-20 20:58 Vincent Sanders Status new => acknowledged
2015-10-20 20:58 Vincent Sanders Product Version => 3.4
2015-10-20 20:58 Vincent Sanders Description Updated View Revisions
2015-10-20 20:58 Vincent Sanders Steps to Reproduce Updated View Revisions
2015-10-20 20:58 Vincent Sanders Additional Information Updated View Revisions
2015-10-30 00:47 Harriet Bazley Note Added: 0000988
2015-10-30 14:09 Vincent Sanders Relationship added duplicate of 0002366
2015-10-30 14:11 Vincent Sanders Note Added: 0000990
2015-10-31 18:55 Dave Higton Fixed in CI build # => 3032
2015-10-31 18:55 Dave Higton Note Added: 0001007
2015-10-31 18:55 Dave Higton Assigned To => Michael Drake
2015-10-31 18:55 Dave Higton Status acknowledged => resolved
2015-10-31 18:55 Dave Higton Resolution open => fixed
2015-10-31 18:55 Dave Higton Fixed in Version => 3.4
2016-02-16 14:46 Vincent Sanders Note Added: 0001279
2016-02-16 14:46 Vincent Sanders Status resolved => closed
+Issue History