2019-03-26 21:16 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002363NetSurfJavascriptpublic2016-02-16 15:10
ReporterChris Young 
Assigned ToDaniel Silverstone 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.4 
Target VersionFixed in Version3.4 
Summary0002363: Embedded Vimeo causes crash
DescriptionEmbedded Vimeo videos appear to cause NetSurf dukky to crash.
Steps To ReproduceVisit http://www.madeinteesside.com
Additional InformationStack trace:
    [javascript/dukky.c:243] dukky_push_node()+0xc4 (section 1 @ 0x121274)
    [javascript/dukky.c:243] dukky_push_node()+0xc4 (section 1 @ 0x121274)
    [javascript/duktape/duktape.c:1364] duk_handle_call()+0x46c (section 1 @ 0x12ADE8)
    [javascript/duktape/duktape.c:84] duk_hobject_getprop()+0x4dc (section 1 @ 0x12FC58)
    [javascript/duktape/duktape.c:2848] duk_js_execute_bytecode()+0x10f8 (section 1 @ 0x12873C)
    [javascript/duktape/duktape.c:1471] duk_handle_call()+0x848 (section 1 @ 0x12B1C4)
    [javascript/duktape/duktape.c:61] duk_eval_raw()+0x18c (section 1 @ 0x14C040)
    [javascript/dukky.c:355] eval_top_string()+0x34 (section 1 @ 0x120D74)
    [javascript/duktape/duktape.c:1876] duk_handle_safe_call()+0x110 (section 1 @ 0x131A10)
    [javascript/dukky.c:366] js_exec()+0xa8 (section 1 @ 0x121A98)
    [render/html_script.c:498] html_process_script()+0x3c0 (section 1 @ 0x185000)
    complete_script()+0x1c (section 1 @ 0x227F40)
    complete_script()+0x34 (section 1 @ 0x258430)
    handle_generic_rcdata()+0x118 (section 1 @ 0x25FBF0)
    hubbub_treebuilder_token_handler()+0x1ec (section 1 @ 0x257C40)
    hubbub_tokeniser_emit_token()+0x38 (section 1 @ 0x24DB24)
    hubbub_tokeniser_handle_tag_name()+0x52c (section 1 @ 0x252B38)
    hubbub_tokeniser_run()+0xc28 (section 1 @ 0x255784)
    hubbub_parser_parse_chunk()+0xb0 (section 1 @ 0x24C67C)
    dom_hubbub_parser_parse_chunk()+0x14 (section 1 @ 0x228E8C)
    [render/html.c:1028] html_process_data()+0x28 (section 1 @ 0x17592C)
    [content/content.c:154] content_llcache_callback()+0x154 (section 1 @ 0xC4E2C)
    [content/llcache.c:2947] llcache_object_notify_users()+0x200 (section 1 @ 0xD5D1C)
    [content/llcache.c:3395] llcache_catch_up_all_users()+0x38 (section 1 @ 0xD5ECC)
    [amiga/schedule.c:239] ami_schedule_handle()+0x178 (section 1 @ 0x379F8)
    [amiga/gui.c:2704] ami_get_msg()+0x5e8 (section 1 @ 0x1C604)
    [amiga/gui.c:5441] main()+0xa80 (section 1 @ 0x1FAB0)
    native kernel module newlib.library.kmod+0x000020ac
    native kernel module newlib.library.kmod+0x00002d14
    native kernel module newlib.library.kmod+0x00002ef0
    _start()+0x170 (section 1 @ 0x16C)
    native kernel module dos.library.kmod+0x00024c18
    native kernel module kernel+0x0003b648
    native kernel module kernel+0x0003b6c8

PPC disassembly:
 6f142290: 7fc4f378 mr r4,r30
 6f142294: 4800b9bd bl 0x6F14DC50
*6f142298: 813e0000 lwz r9,0(r30)
 6f14229c: 7fc3f378 mr r3,r30
 6f1422a0: 38810008 addi r4,r1,8
TagsNo tags attached.
Fixed in CI build #3005
Reported in CI build #2982
URL of problem pagehttp://www.madeinteesside.com
Attached Files
  • log file icon ns.log (173,884 bytes) 2015-10-10 17:49

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000956

Vincent Sanders (administrator)

Another new and exciting javascript explosion
Dave Higton

~0000960

Dave Higton (developer)

Last edited: 2015-10-17 21:17

View 2 revisions

A more direct URL to show the problem is http://player.vimeo.com/video/54987062

I verified in #2999 that it still crashes. I see duktape pushing node 0, which I guess is not right.

Chris Young

~0000977

Chris Young (developer)

Confirmed fixed in CI#3005
Vincent Sanders

~0001287

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-10-10 17:49 Chris Young New Issue
2015-10-10 17:49 Chris Young File Added: ns.log
2015-10-12 20:53 Vincent Sanders Note Added: 0000956
2015-10-12 20:53 Vincent Sanders Status new => acknowledged
2015-10-12 20:53 Vincent Sanders Additional Information Updated View Revisions
2015-10-17 21:16 Dave Higton Note Added: 0000960
2015-10-17 21:17 Dave Higton Note Edited: 0000960 View Revisions
2015-10-23 16:12 Chris Young Fixed in CI build # => 3005
2015-10-23 16:12 Chris Young Note Added: 0000977
2015-10-23 16:12 Chris Young Status acknowledged => resolved
2015-10-23 16:12 Chris Young Fixed in Version => 3.4
2015-10-23 16:12 Chris Young Resolution open => fixed
2015-10-23 16:12 Chris Young Assigned To => Daniel Silverstone
2016-02-16 15:10 Vincent Sanders Note Added: 0001287
2016-02-16 15:10 Vincent Sanders Status resolved => closed
+Issue History