2019-01-16 17:19 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002362NetSurfJavascriptpublic2016-02-16 15:24
ReporterDave Higton 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformIyonix, 512 MiBOSRISC OSOS Version5.22
Product Version3.4 
Target VersionFixed in Version3.4 
Summary0002362: Slashdot crashes NS when JS enabled
DescriptionWhen NS has JS enabled, visit http://slashdot.org and NS crashes.
Steps To ReproduceEnable JS. Visit http://slashdot.org
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2968
URL of problem pagehttp://slashdot.org
Attached Files
  • zip file icon Log.zip (10,261 bytes) 2015-10-05 19:37

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000950

Vincent Sanders (administrator)

caused by assert in document.write

The dom private call returns with htmlc as null

I changed it so this reports an error instead of assert. not obvious why the dom call returns null
Vincent Sanders

~0000952

Vincent Sanders (administrator)

netsurf core does not handle multiple document contexts with nested parsing contexts because it is very complex and for now logging the missing implementation is adequate
Vincent Sanders

~0001294

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-10-05 19:37 Dave Higton New Issue
2015-10-05 19:37 Dave Higton File Added: Log.zip
2015-10-06 08:18 Vincent Sanders Note Added: 0000950
2015-10-06 08:18 Vincent Sanders Status new => confirmed
2015-10-06 08:18 Vincent Sanders Product Version => 3.4
2015-10-12 20:48 Vincent Sanders Note Added: 0000952
2015-10-12 20:48 Vincent Sanders Assigned To => Vincent Sanders
2015-10-12 20:48 Vincent Sanders Status confirmed => resolved
2015-10-12 20:48 Vincent Sanders Resolution open => fixed
2015-10-12 20:48 Vincent Sanders Category RISC OS-specific => Javascript
2015-10-12 20:48 Vincent Sanders Fixed in Version => 3.4
2016-02-16 15:24 Vincent Sanders Note Added: 0001294
2016-02-16 15:24 Vincent Sanders Status resolved => closed
+Issue History