2019-01-22 02:48 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002355NetSurfRISC OS-specificpublic2016-02-16 15:24
ReporterKrzysztof Staniorowski 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRaspberry Pi B+ (single core, 51OSRISC OS (latest image)OS Version5.21
Product Version3.3 
Target VersionFixed in Version3.4 
Summary0002355: NetSurf crashes when opening
DescriptionNetSurf violently crashes while trying to open a provided link (Arch Linux wiki).
Steps To ReproduceOne has to google for "nfs arch linux" and then click the first result to reproduce (url provided). Probably it would work with other articles in their wiki.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem pagehttps://wiki.archlinux.org/index.php/NFS
Attached Files
  • ? file icon Log (54,239 bytes) 2015-09-12 22:06 -
    ? file icon Log (54,239 bytes) 2015-09-12 22:06 +

-Relationships
+Relationships

-Notes
Krzysztof Staniorowski

~0000940

Krzysztof Staniorowski (reporter)

I'm so sorry if something was filled incorrectly - it was my first submission in this bugtracker.
Vincent Sanders

~0000941

Vincent Sanders (administrator)

this crash is caused by a know and fixed bug in the svg library. This will not be a problem with the next release.

If you would like to test the next release test builds please feel free to try http://ci.netsurf-browser.org/
Vincent Sanders

~0001296

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-09-12 22:06 Krzysztof Staniorowski New Issue
2015-09-12 22:06 Krzysztof Staniorowski File Added: Log
2015-09-12 22:10 Krzysztof Staniorowski Note Added: 0000940
2015-09-13 22:50 Vincent Sanders Note Added: 0000941
2015-09-13 22:50 Vincent Sanders Assigned To => Vincent Sanders
2015-09-13 22:50 Vincent Sanders Status new => resolved
2015-09-13 22:50 Vincent Sanders Resolution open => fixed
2015-09-13 22:50 Vincent Sanders Product Version => 3.3
2015-09-13 22:50 Vincent Sanders Fixed in Version => 3.4
2016-02-16 15:24 Vincent Sanders Note Added: 0001296
2016-02-16 15:24 Vincent Sanders Status resolved => closed
+Issue History