2019-01-22 02:48 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002353NetSurfJavascriptpublic2016-02-16 14:44
ReporterRichard Porter 
Assigned ToDaniel Silverstone 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.16
Product Version3.4 
Target VersionFixed in Version3.4 
Summary0002353: Crash on stopping
DescriptionI tried to open a link in an email message in Messenger Pro. The URL passed to NetSurf incorrectly included the closing bracket. I clicked Select on the X icon to stop the transfer upon which NetSurf aborted.
Steps To ReproduceAttempt to open problem link.
Click X icon while request is being processed.
TagsNo tags attached.
Fixed in CI build #3031
Reported in CI build #2926
URL of problem pagehttp://store.three.co.uk/view/product/ql_catalog/threecatdevice/1021)
Attached Files

-Relationships
duplicate of 0002369closedDaniel Silverstone Immediate crash upon closing a window after google search. 
+Relationships

-Notes
Vincent Sanders

~0000943

Vincent Sanders (administrator)

javascript failed as ctx was null
Vincent Sanders

~0001001

Vincent Sanders (administrator)

(9.510000) content/content.c:282 content_convert: content http://store.three.co.uk/three-uk/js/three/jquery-cookie.js (0x3a243e38)
(9.510000) render/html_script.c:266 convert_script_sync_cb: script 1 done 'http://store.three.co.uk/three-uk/js/three/jquery-cookie.js'
(9.510000) render/html_script.c:268 convert_script_sync_cb: 0 fetches active

"javascript/dukky.c", line 392: js_exec: Assertion failed: ctx
Vincent Sanders

~0001274

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-08-26 11:20 Richard Porter New Issue
2015-08-26 11:20 Richard Porter File Added: nslog318.zip
2015-09-23 12:15 Vincent Sanders Note Added: 0000943
2015-09-23 12:15 Vincent Sanders Status new => acknowledged
2015-09-23 12:15 Vincent Sanders Category General => Javascript
2015-09-23 12:15 Vincent Sanders Product Version => 3.4
2015-09-23 12:15 Vincent Sanders Steps to Reproduce Updated View Revisions
2015-10-31 15:34 Vincent Sanders Note Added: 0001001
2015-10-31 15:35 Vincent Sanders Relationship added duplicate of 0002369
2015-10-31 19:14 Vincent Sanders Fixed in CI build # => 3031
2015-10-31 19:14 Vincent Sanders Assigned To => Daniel Silverstone
2015-10-31 19:14 Vincent Sanders Status acknowledged => resolved
2015-10-31 19:14 Vincent Sanders Resolution open => fixed
2015-10-31 19:14 Vincent Sanders Fixed in Version => 3.4
2016-02-16 14:44 Vincent Sanders Note Added: 0001274
2016-02-16 14:44 Vincent Sanders Status resolved => closed
+Issue History