2019-01-16 17:30 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002348NetSurf[All Projects] Generalpublic2016-02-16 15:08
ReporterRichard Porter 
Assigned To 
SeveritymajorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.16
Product Version3.4 
Target VersionFixed in Version3.4 
Summary0002348: Looping
DescriptionAfter entering my username and password NS just sits there looping, showing "fetching. fetching. processing" at the bottom. I stopped it with Alt-Break and got the attached log (316).
Steps To ReproduceGo to problem page, enter any username and password - it doesn't need to be a valid one.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2899
URL of problem pagehttps://myaccount.fuelbroadband.co.uk
Attached Files

-Relationships
duplicate of 0002366closedMichael Drake JS lockup 
+Relationships

-Notes
Vincent Sanders

~0000992

Vincent Sanders (administrator)

Is this still an issue with current development editions
Richard Porter

~0000993

Richard Porter (reporter)

With javascript enabled NS loops when trying to load the problem page. I don't get as far as entering the login details. See log 321.
With javascript disabled I can now log in and download my statement. However the login fields are not displayed correctly, being only about one character wide.
Richard Porter

~0000994

Richard Porter (reporter)

PS now running #3021.
Dave Higton

~0001006

Dave Higton (developer)

NS does /not/ loop infinitely; it took an unreasonably long time to complete its operation. This has been enormously speed up recently. A good example is CI#3032. This is the same cause as bug 2366 which is now resolved.

Richard: please raise another issue for the login fields not being displayed correctly.
Vincent Sanders

~0001280

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-08-14 12:11 Richard Porter New Issue
2015-08-14 12:11 Richard Porter File Added: nslog316.zip
2015-08-24 13:05 Vincent Sanders Severity block => major
2015-08-24 13:05 Vincent Sanders Status new => acknowledged
2015-08-24 13:05 Vincent Sanders Product Version => 3.4
2015-10-30 15:07 Vincent Sanders Note Added: 0000992
2015-10-30 15:07 Vincent Sanders Status acknowledged => feedback
2015-10-30 18:38 Richard Porter Note Added: 0000993
2015-10-30 18:38 Richard Porter Status feedback => new
2015-10-30 18:39 Richard Porter File Added: nslog321.zip
2015-10-30 18:40 Richard Porter Note Added: 0000994
2015-10-31 16:54 Vincent Sanders Status new => acknowledged
2015-10-31 18:18 Vincent Sanders Sticky Issue No => Yes
2015-10-31 18:18 Vincent Sanders Sticky Issue Yes => No
2015-10-31 18:36 Dave Higton Note Added: 0001006
2015-10-31 18:39 Dave Higton Status acknowledged => resolved
2015-10-31 18:39 Dave Higton Resolution open => fixed
2015-10-31 18:39 Dave Higton Fixed in Version => 3.4
2015-10-31 18:46 Vincent Sanders Relationship added duplicate of 0002366
2016-02-16 15:08 Vincent Sanders Note Added: 0001280
2016-02-16 15:08 Vincent Sanders Status resolved => closed
+Issue History