2019-03-22 07:03 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002308NetSurfJavascriptpublic2017-10-16 22:35
ReporterPeter Young 
Assigned To 
SeveritymajorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformArMINIOSRISC OSOS Version5.19
Product Version3.0 
Target VersionFixed in Version3.7 
Summary0002308: Odd error message
DescriptionI tried to access http://www.remapglos.org.uk/ and get "Warning from
NetSurf: OK". No crash, but the attempt to load the page stops there. The site works properly on Chrome in Windows. Zipped logfile attached.

I have been unable to report this in RISC OS NetSurf; see postings on the mailing list.
Steps To ReproduceRepeat attempt
TagsNo tags attached.
Fixed in CI build #4213
Reported in CI build #2720
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Peter Young

~0000829

Peter Young (reporter)

A comment from Brian Jordan on the meiling list. I don't understand it, but maybe the developers can:

If you want to enhance your report Netsurf is being tripped up by the
following meta statement within the <head></head> of the document.

<meta http-equiv="Content-Type" content=
  "text/html; charset=us-ascii" />

An interesting page in many ways, running it through HTML Tidy here
throws up a lot of warnings and concludes "Info: Document content looks
like HTML Proprietary"
David Pitt

~0000830

David Pitt (reporter)

This appears to be a JavaScript issue, the site loads without error if JavaScript is disabled.
Dave Higton

~0001192

Dave Higton (developer)

Please try this with a current CI build - it works for me in CI #3348 with Javascript enabled, so I think it may have been fixed somewhere along the way.
David Pitt

~0001195

David Pitt (reporter)

The 'OK' fault is still present here with #3348 with Javascript enabled, and on one occassion NetSurf crashed out with a Segmentation fault though that is not repeatable. The logged line is :-

riscos/gui.c:2072 warn_user: OK (null)

Tested on both the Raspberry Pi and A9home.

Log 2308djp uploaded.
Peter Young

~0001211

Peter Young (reporter)

TRied it here (ARMX6, RISCOS 5.23, NetSurf #33644) and I still get the "OK" and then an hourglass, and need to do alt-break to get back control, so no logfile is available.
Dave Higton

~0001614

Dave Higton (developer)

Peter, can you try with a current dev version, please? I've just tried it with the current dev version (4213) on RO 5.23 of about 4 weeks ago, and it appears to work fine.
Peter Young

~0001615

Peter Young (reporter)

Yes, working perfectly now. Many thanks. I'd forgtten about this one!
Dave Higton

~0001618

Dave Higton (developer)

Don't know when it was fixed - the problem was originally reported in a very old version.
Vincent Sanders

~0001647

Vincent Sanders (administrator)

Thankyou for your report, this has been resolved in the 3.7 release
+Notes

-Issue History
Date Modified Username Field Change
2015-04-14 20:00 Peter Young New Issue
2015-04-14 20:00 Peter Young File Added: Logfile.zip
2015-04-15 08:08 Peter Young Note Added: 0000829
2015-04-15 08:42 David Pitt Note Added: 0000830
2015-04-20 09:18 Vincent Sanders Status new => acknowledged
2015-04-20 09:18 Vincent Sanders Category RISC OS-specific => Javascript
2016-02-04 22:27 Dave Higton Note Added: 0001192
2016-02-05 06:34 David Pitt File Added: 2308djp.zip
2016-02-05 06:38 David Pitt Note Added: 0001195
2016-02-08 16:54 Peter Young Note Added: 0001211
2017-10-02 20:53 Dave Higton Note Added: 0001614
2017-10-02 21:06 Peter Young Note Added: 0001615
2017-10-02 21:44 Dave Higton Status acknowledged => resolved
2017-10-02 21:44 Dave Higton Resolution open => fixed
2017-10-02 21:44 Dave Higton Fixed in Version => 3.7
2017-10-02 21:44 Dave Higton Description Updated View Revisions
2017-10-02 21:44 Dave Higton Fixed in CI build # => 4213
2017-10-02 21:44 Dave Higton Note Added: 0001618
2017-10-16 22:35 Vincent Sanders Status resolved => closed
2017-10-16 22:35 Vincent Sanders Description Updated View Revisions
2017-10-16 22:35 Vincent Sanders Note Added: 0001647
+Issue History