2019-09-21 10:33 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002305NetSurfWin32-specificpublic2016-04-12 11:46
ReporterJonás Perusquía 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformReal HardwareOSWindowsOS Version7 x64
Product Version3.3 
Target VersionFixed in Version3.5 
Summary0002305: Crash when trying to access Prodigy MSN
DescriptionNetSurf crashes and shows this error:

Assertion failed!

Program: C:\Program Files (x86)\NetSurf\NetSurf\NetSurf.exe
File: content/content.c, Line 359

Expression: c->locked == false
Steps To Reproducewrite in the URL bar the address: http://prodigy.msn.com/es-mx/
TagsNo tags attached.
Fixed in CI build #3443
Reported in CI build #
URL of problem pagehttp://prodigy.msn.com/es-mx/
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000826

Vincent Sanders (administrator)

I am unable to reproduce this myself although I have fixed the "missing" jpeg issue recently. Can you try with an updated CI release?

If the issue persists can you please ensure you report the CI version (the about dialogue should have this number)

If the issue is reproducible perhaps you can run the executable from the command line with the -v option and capture the debug output and attach it.
Jonás Perusquía

~0000828

Jonás Perusquía (reporter)

Tried again but now it only crashes, I managed to open the website only once... but the rest of the attempts (around 10) it just crashed.
#CI build: 2720
Vincent Sanders

~0001351

Vincent Sanders (administrator)

added a quick n dirty OCR conversion of the log fragment so it can be easily read
Vincent Sanders

~0001352

Vincent Sanders (administrator)

caused by bad usage of browser_window_reformat() API.

fixed in commit 69d9d5dd224f974f69b32267757aff2089a4c12a
Vincent Sanders

~0001368

Vincent Sanders (administrator)

confirmed resolved in 3.5
+Notes

-Issue History
Date Modified Username Field Change
2015-04-09 08:38 Jonás Perusquía New Issue
2015-04-09 08:38 Jonás Perusquía File Added: netsurf.png
2015-04-09 08:49 Vincent Sanders Assigned To => Vincent Sanders
2015-04-09 08:49 Vincent Sanders Status new => acknowledged
2015-04-13 10:54 Vincent Sanders Note Added: 0000826
2015-04-13 10:54 Vincent Sanders Status acknowledged => feedback
2015-04-14 04:27 Jonás Perusquía Note Added: 0000828
2015-04-14 04:27 Jonás Perusquía Status feedback => assigned
2015-04-14 05:24 Jonás Perusquía File Added: debug.png
2015-04-20 10:19 Vincent Sanders Status assigned => confirmed
2015-04-20 10:19 Vincent Sanders Target Version => 3.4
2016-02-09 11:02 Michael Drake Target Version 3.4 =>
2016-03-16 11:46 Vincent Sanders File Added: 043509_debug (1).txt
2016-03-16 11:47 Vincent Sanders Note Added: 0001351
2016-03-16 21:33 Vincent Sanders Fixed in CI build # => 3443
2016-03-16 21:33 Vincent Sanders Note Added: 0001352
2016-03-16 21:33 Vincent Sanders Status confirmed => resolved
2016-03-16 21:33 Vincent Sanders Resolution open => fixed
2016-03-16 21:33 Vincent Sanders Fixed in Version => 3.5
2016-04-12 11:46 Vincent Sanders Note Added: 0001368
2016-04-12 11:46 Vincent Sanders Status resolved => closed
+Issue History