2019-01-22 02:59 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002290LibParserUtils[All Projects] Generalpublic2016-11-22 22:03
Reporterrkd 
Assigned ToVincent Sanders 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformi686OSLinuxOS Version
Product Version0.2.1 
Target VersionFixed in Version0.2.2 
Summary0002290: Compilation with fresh glibc fails
DescriptionCompilation with glibc-2.21 fails because of -Werror and such warnings:
In file included from /usr/include/errno.h:28:0,
                 from src/input/filter.c:8:
/usr/include/features.h:148:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"

The same applies to other netsurf libraries built with -Werror
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
Attached Files

-Relationships
+Relationships

-Notes
rkd

~0000785

rkd (reporter)

To quiet down warnings add -D_DEFAULT_SOURCE to CFLAGS.
In the uploaded file patches for a few netsurf libraries.
Vincent Sanders

~0000800

Vincent Sanders (administrator)

I have committed changes similar to your suggested solution to all NetSurf libraries and tools that define _BSD_SOURCE

Thanks for the report. The next release of netsurf will have these changes in by default.
Vincent Sanders

~0001438

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2015-03-16 16:11 rkd New Issue
2015-03-17 11:18 rkd Note Added: 0000785
2015-03-17 11:19 rkd File Added: _DEFAULT_SOURCE.tar.gz
2015-03-22 16:57 Vincent Sanders Note Added: 0000800
2015-03-22 16:57 Vincent Sanders Assigned To => Vincent Sanders
2015-03-22 16:57 Vincent Sanders Status new => resolved
2015-03-22 16:57 Vincent Sanders Resolution open => fixed
2015-03-22 17:02 Vincent Sanders Product Version => 0.2.1
2015-03-22 17:02 Vincent Sanders Fixed in Version => 0.2.2
2016-11-22 22:03 Vincent Sanders Note Added: 0001438
2016-11-22 22:03 Vincent Sanders Status resolved => closed
+Issue History