2019-01-16 17:26 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002232NetSurfAmiga-specificpublic2015-03-10 23:43
ReporterChris Young 
Assigned ToChris Young 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.3 
Target VersionFixed in Version3.3 
Summary0002232: Crash on exit
DescriptionNetSurf crashes on exit in html_css_free_stylesheets().
This is a new phenomenon in the last couple of days.
Steps To ReproduceWhat I did (although I'm not sure the intermediary step is necessary:
Start up NetSurf
Visit www.aminet.net
Quit NetSurf
Additional InformationLast log line before forcing a continue in the OS:
(29.728382) render/html.c html_destroy 1397: content 0x59028b58

Stack trace:
    native kernel module kernel+0x00012b80
    native kernel module kernel+0x00018818
    [render/html_css.c:467] html_css_free_stylesheets()+0x44 (section 1 @ 0xD0B98)
    [render/html.c:1466] html_destroy()+0x1d0 (section 1 @ 0xCCBCC)
    [content/content.c:390] content_destroy()+0x50 (section 1 @ 0x6FF60)
    [content/hlcache.c:139] hlcache_clean()+0x94 (section 1 @ 0x79804)
    [content/hlcache.c:569] hlcache_finalise()+0x88 (section 1 @ 0x7A0C8)
    [desktop/netsurf.c:268] netsurf_exit()+0x6c (section 1 @ 0xA2544)
    [amiga/gui.c:5440] main()+0xb5c (section 1 @ 0x1F7BC)
    native kernel module newlib.library.kmod+0x000020ac
    native kernel module newlib.library.kmod+0x00002d14
    native kernel module newlib.library.kmod+0x00002ef0
    _start()+0x170 (section 1 @ 0x16C)
    native kernel module dos.library.kmod+0x00024bb0
    native kernel module kernel+0x0003b4b0
    native kernel module kernel+0x0003b530
TagsNo tags attached.
Fixed in CI build #2415
Reported in CI build #2414
URL of problem page
Attached Files
  • log file icon ns.log (168,250 bytes) 2014-12-01 21:40

-Relationships
+Relationships

-Notes
Chris Young

~0000547

Chris Young (developer)

Just realised the cause of this.
Chris Young

~0000548

Chris Young (developer)

Fixed in 2415
Caused by sending messages to a dealloc'ed message port.
Vincent Sanders

~0000752

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2014-12-01 21:40 Chris Young New Issue
2014-12-01 21:40 Chris Young File Added: ns.log
2014-12-01 21:42 Chris Young Assigned To => Chris Young
2014-12-01 21:42 Chris Young Status new => assigned
2014-12-01 21:43 Chris Young Note Added: 0000547
2014-12-01 21:43 Chris Young Category General => Amiga-specific
2014-12-01 21:58 Chris Young Fixed in CI build # => 2415
2014-12-01 21:58 Chris Young Note Added: 0000548
2014-12-01 21:58 Chris Young Status assigned => resolved
2014-12-01 21:58 Chris Young Fixed in Version => 3.3
2014-12-01 21:58 Chris Young Resolution open => fixed
2015-03-10 23:43 Vincent Sanders Note Added: 0000752
2015-03-10 23:43 Vincent Sanders Status resolved => closed
+Issue History