2019-01-22 02:54 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002212NetSurfRISC OS-specificpublic2016-02-16 14:11
ReporterPeter Young 
Assigned ToMichael Drake 
SeveritycrashReproducibilityunable to reproduce 
StatusclosedResolutionfixed 
PlatformRISC OSOSRISC OS OS Version5.19
Product Version3.3 
Target VersionFixed in Version3.4 
Summary0002212: Crash on BBC News site.
DescriptionARMini, FWI1W. Loaded www.bbc.co.uk/news, and from there tried to load http://www.bbc.co.uk/news/uk-england-cornwall-29779021 resutling in an immediate crash. Zipped logfile herewith.
Steps To ReproduceHaven't tried, as the site may have changed since the attempt
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2247
URL of problem pagehttp://www.bbc.co.uk/news/uk-england-cornwall-29779021
Attached Files

-Relationships
duplicate of 0002245closed Crash on The Register 
has duplicate 0002215closed Crash on The Register 
+Relationships

-Notes
Vincent Sanders

~0000516

Vincent Sanders (administrator)

urldb asserting

"content/urldb.c", line 1964: urldb_match_path: Assertion failed: path[0] == '/'

  ( 6ad498) pc: 44610 lr: 44b90 sp: 6ad49c ^urldb_find_url()
  ( 6ad4a8) pc: 44b7c lr: 50d1c sp: 6ad4ac urldb_get_url_data()
  ( 6ad4d0) pc: 50c14 lr: 3217bc sp: 6ad4d4 ^node_is_visited()
  ( 6ad508) pc: 3211cc lr: 3220bc sp: 6ad50c ^match_details()
  ( 6b298c) pc: 321a88 lr: 4a9c1c sp: 6b2990 css_select_style()
  ( 6b29b8) pc: 4eb64 lr: 86e04 sp: 6b29bc nscss_get_style()
  ( 6b2b34) pc: 86544 lr: d2a28 sp: 6b2b38 ^convert_xml_to_box()
  ( 6b2b54) pc: d29e0 lr: be6a4 sp: 6b2b58 schedule_run()
  ( 6b2e1c) pc: be468 lr: bf750 sp: 6b2e20 ^riscos_poll()
  ( 6b2fe8) pc: bf0d0 lr: 4a9700 sp: 6b2fec main()
Vincent Sanders

~0000518

Vincent Sanders (administrator)

If you can reproduce this I would be very interested in the new log, most recent CI build (2266) has additional logging in this part of urldb which should let me understand what bad bad urldb is choking on.
Peter Young

~0000519

Peter Young (reporter)

I've just tried that URL again with development versions 2264 and 2266, and there was no crash. However, I had to access the URL directly, not through www.bbc.co.uk/news, as the original page is long gone/ This may mean that the steps to reproduce couldn't be done exactly.
Vincent Sanders

~0000523

Vincent Sanders (administrator)

Thanks to the duplicate 2215 giving the additional debugging hint I needed I can now say this is caused by urldb choking when asked to check the visited status of mailto: urls

In the case of the example on the register it was their "Tips & Corrections" link which is

mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20BBC%20clamps%20down%20on%20ILLICIT%20iPlayer%20watchers&body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2014/11/03/beeb_clamps_down_on_naughty_iplayer_watching/

and for some reason on RISC OS is causing the path assert to be triggered (this does not occur on GTK)
Peter Young

~0000770

Peter Young (reporter)

I reported this one, and haven't come across a simiar crssh since. I use the BBC news site quite a lot, and I think this bug could be closed now.
Dave Higton

~0001148

Dave Higton (developer)

I've tried again with RISC OS build 3252, and was again unable to reproduce the problem, so, as the OP suggests, I'm closing it.
Michael Drake

~0001153

Michael Drake (administrator)

> and for some reason on RISC OS is causing the path assert to be triggered (this does not occur on GTK)

Nothing to do with RISC OS/GTK, but rather the contents of your URLdb.

When we test whether a URL exists in the DB for :visted support we use a bloom filter to speed up the case where its not there. If there is a hash collision then we actually have to do the test fully and hit this assert.
Vincent Sanders

~0001245

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2014-10-27 17:55 Peter Young New Issue
2014-10-27 17:55 Peter Young File Added: Logfile.zip
2014-10-31 21:06 Vincent Sanders Status new => acknowledged
2014-10-31 21:06 Vincent Sanders Product Version => 3.3
2014-10-31 21:09 Vincent Sanders Note Added: 0000516
2014-11-02 00:01 Vincent Sanders Note Added: 0000518
2014-11-02 07:55 Peter Young Note Added: 0000519
2014-11-03 17:53 Vincent Sanders Relationship added has duplicate 0002215
2014-11-03 17:58 Vincent Sanders Note Added: 0000523
2015-03-15 17:11 Peter Young Note Added: 0000770
2016-01-07 22:36 Dave Higton Note Added: 0001148
2016-01-07 22:36 Dave Higton Reproducibility have not tried => unable to reproduce
2016-01-07 22:36 Dave Higton Status acknowledged => closed
2016-01-08 15:03 Michael Drake Note Added: 0001153
2016-01-08 15:04 Michael Drake Resolution open => duplicate
2016-01-08 15:04 Michael Drake Relationship added duplicate of 0002245
2016-01-08 23:09 Vincent Sanders Assigned To => Michael Drake
2016-01-08 23:09 Vincent Sanders Status closed => resolved
2016-01-08 23:09 Vincent Sanders Resolution duplicate => fixed
2016-01-08 23:09 Vincent Sanders Fixed in Version => 3.4
2016-02-16 14:11 Vincent Sanders Note Added: 0001245
2016-02-16 14:11 Vincent Sanders Status resolved => closed
+Issue History