2019-03-22 07:01 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002205NetSurfAmiga-specificpublic2015-03-10 23:44
ReporterSamir Hawamdeh 
Assigned ToChris Young 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.2
Product Version3.2 
Target VersionFixed in Version3.3 
Summary0002205: Crash when closing bookmark window
DescriptionNetSurf will crash if you try to close the bookmark window after you have closed the main window of NetSurf.

This happen because if you have both window opened on screen, but then you close NetSurf, the bookmark window still opened rathen then be closed togheter of the main window.

TagsNo tags attached.
Fixed in CI build #2195
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0000505

Chris Young (developer)

This is caused by a scheduled event (throbber update) still pointing to the window even though it is closed. The fix will be to remove the schedule on window close.

Curiously this happens even when the throbber isn't active, but doesn't happen when opening a new window and then closing it.
Chris Young

~0000511

Chris Young (developer)

Fixed in CI#2195
Vincent Sanders

~0000760

Vincent Sanders (administrator)

Confirmed fixed in 3.3 release
+Notes

-Issue History
Date Modified Username Field Change
2014-10-08 15:36 Samir Hawamdeh New Issue
2014-10-08 15:36 Samir Hawamdeh File Added: Crashlog_NetSurf_2014-10-08_05-50-18.txt
2014-10-08 22:55 Chris Young Assigned To => Chris Young
2014-10-08 22:55 Chris Young Status new => assigned
2014-10-08 23:00 Chris Young Note Added: 0000505
2014-10-08 23:00 Chris Young Status assigned => confirmed
2014-10-23 17:58 Chris Young Fixed in CI build # => 2195
2014-10-23 17:58 Chris Young Note Added: 0000511
2014-10-23 17:58 Chris Young Status confirmed => resolved
2014-10-23 17:58 Chris Young Fixed in Version => 3.3
2014-10-23 17:58 Chris Young Resolution open => fixed
2015-03-10 23:44 Vincent Sanders Note Added: 0000760
2015-03-10 23:44 Vincent Sanders Status resolved => closed
+Issue History