2019-03-26 21:19 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002191Hubbub[All Projects] Generalpublic2016-11-22 22:01
ReporterAnthony J. Bentley 
Assigned ToVincent Sanders 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version0.3.1 
Target VersionFixed in Version0.3.2 
Summary0002191: json-c header location change
DescriptionEither in 0.10 or 0.11, json-c did a mass rename of “json” to “json-c” (include/json-c, libjson-c.so, json-c.pc, etc.) This causes “make test” to fail on a system with new json-c when running hubbub regression tests.

Since OpenBSD has a newer version of json-c than that, I use the attached patch (which uses the updated json-c locations) for hubbub regression tests. But since it removes support for the old locations, if you want to support systems that may have an older json-c, it might not be appropriate.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
Attached Files
  • ? file icon patch-Makefile (785 bytes) 2014-09-04 06:56 -
    $OpenBSD$
    --- Makefile.orig	Thu Sep  4 00:19:34 2014
    +++ Makefile	Thu Sep  4 00:20:49 2014
    @@ -47,12 +47,12 @@ ifeq ($(WANT_TEST),yes)
       # We require the presence of libjson -- http://oss.metaparadigm.com/json-c/
       ifneq ($(PKGCONFIG),)
         TESTCFLAGS := $(TESTCFLAGS) \
    -		$(shell $(PKGCONFIG) $(PKGCONFIGFLAGS) --cflags json)
    +		$(shell $(PKGCONFIG) $(PKGCONFIGFLAGS) --cflags json-c)
         TESTLDFLAGS := $(TESTLDFLAGS) \
    -		$(shell $(PKGCONFIG) $(PKGCONFIGFLAGS) --libs json)
    +		$(shell $(PKGCONFIG) $(PKGCONFIGFLAGS) --libs json-c)
       else
    -    TESTCFLAGS := $(TESTCFLAGS) -I$(PREFIX)/include/json
    -    TESTLDFLAGS := $(TESTLDFLAGS) -ljson
    +    TESTCFLAGS := $(TESTCFLAGS) -I$(PREFIX)/include/json-c
    +    TESTLDFLAGS := $(TESTLDFLAGS) -ljson-c
       endif
     
       ifneq ($(GCCVER),2)
    
    ? file icon patch-Makefile (785 bytes) 2014-09-04 06:56 +

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000799

Vincent Sanders (administrator)

committed your fix, thanks
Vincent Sanders

~0001435

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2014-09-04 06:56 Anthony J. Bentley New Issue
2014-09-04 06:56 Anthony J. Bentley File Added: patch-Makefile
2014-09-04 10:23 Vincent Sanders Assigned To => Vincent Sanders
2014-09-04 10:23 Vincent Sanders Status new => acknowledged
2014-09-04 10:23 Vincent Sanders Product Version => 3.3
2015-03-22 00:32 Vincent Sanders Note Added: 0000799
2015-03-22 00:32 Vincent Sanders Status acknowledged => resolved
2015-03-22 00:32 Vincent Sanders Fixed in Version => 3.4
2015-03-22 17:03 Vincent Sanders Project NetSurf => Hubbub
2015-03-22 17:06 Vincent Sanders Product Version 3.3 => 0.3.1
2015-03-22 17:06 Vincent Sanders Fixed in Version 3.4 => 0.3.2
2015-11-04 08:49 Vincent Sanders Resolution open => fixed
2016-11-22 22:01 Vincent Sanders Note Added: 0001435
2016-11-22 22:01 Vincent Sanders Status resolved => closed
+Issue History