2024-07-15 11:48 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002174NetSurf[All Projects] Generalpublic2014-12-01 15:32
ReporterRichard Porter 
Assigned To 
PlatformRiscPCOSRISC OSOS Version6.14
Product Version 
Target VersionFixed in Version 
Summary0002174: Failed writing header
DescriptionTrying to reaise a question to PlusNet support. When I submit the form I got the error message something like "failed writing header". I then ran version 2.9 and raised a question without trouble. Returning to 2026 I tried again and just got a blank error message every time.
Steps To ReproduceYou will need someone with a PlusNet account. Log in to the Member Centre and go to the problem page. Enter details and submit the form.
Additional InformationLog file attached.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #2026
URL of problem pagehttps://portal.plus.net/wizard/?q=new_question
Attached Files

has duplicate 0002210closed Failed writing header 

Vincent Sanders


Vincent Sanders (administrator)

I have fixed the error reporting from curl, can you try a form submission again and report the full error text?

Additionally a save of the form page would be useful as it may be the actual form being submitted.
Richard Porter


Richard Porter (reporter)

Tried it again on 0002335 and it still comes up with "Failed writing header". Nothing else.
Vincent Sanders


Vincent Sanders (administrator)

alas the change only went into 2336, please can you try with that.
Richard Porter


Richard Porter (reporter)

It;s different! This time I get "A libout function was given a bad argument".
Michael Drake


Michael Drake (administrator)

Can you try this:

1. Quit NetSurf
2. Set "suppress_curl_debug:0" in NetSurf's Choices file.
3. Restart NetSurf.
4. Try again.
5. Send us the log.
6. Quit NetSurf.
7. Undo the change at step 2.
Richard Porter


Richard Porter (reporter)

Same result. Log uploaded.
Vincent Sanders


Vincent Sanders (administrator)

is it possible to do a full save of the form submission page and attach the result to the bug please?
Richard Porter


Richard Porter (reporter)

Latest build (2413), same reslt. The form submission page is uploaded as "wizard". I've also uploaded the log (nslog307).
Richard Porter


Richard Porter (reporter)

Sorry, full save now uploaded.

-Issue History
Date Modified Username Field Change
2014-07-24 15:23 Richard Porter New Issue
2014-07-24 15:23 Richard Porter File Added: nslog301.zip
2014-07-24 16:10 Vincent Sanders Status new => acknowledged
2014-11-05 13:26 Vincent Sanders Relationship added has duplicate 0002210
2014-11-15 18:35 Vincent Sanders Note Added: 0000533
2014-11-15 18:35 Vincent Sanders Status acknowledged => feedback
2014-11-15 20:30 Richard Porter Note Added: 0000534
2014-11-15 20:30 Richard Porter Status feedback => new
2014-11-15 20:44 Vincent Sanders Note Added: 0000535
2014-11-15 20:44 Vincent Sanders Status new => feedback
2014-11-15 22:03 Richard Porter Note Added: 0000536
2014-11-15 22:03 Richard Porter Status feedback => new
2014-11-16 09:46 Michael Drake Note Added: 0000537
2014-11-16 11:09 Richard Porter Note Added: 0000538
2014-11-16 11:10 Richard Porter File Added: nslog306.zip
2014-12-01 14:37 Vincent Sanders Status new => acknowledged
2014-12-01 14:38 Vincent Sanders Note Added: 0000543
2014-12-01 15:22 Richard Porter File Added: wizard
2014-12-01 15:23 Richard Porter File Added: nslog307.zip
2014-12-01 15:25 Richard Porter Note Added: 0000544
2014-12-01 15:31 Richard Porter File Added: wizard.zip
2014-12-01 15:32 Richard Porter Note Added: 0000545
+Issue History