2019-01-22 03:05 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002167NetSurfAmiga-specificpublic2015-03-10 11:12
ReporterChris Young 
Assigned ToChris Young 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.2 
Target Version3.2Fixed in Version3.2 
Summary0002167: Find in page hangs on long pages
DescriptionFind in page never completes on long pages.
Steps To ReproduceVisit http://sox.sourceforge.net/sox.html
Find in page for "sox".
Either click Next a few times, or select "Show All"
NetSurf hangs
Additional InformationAppears to happen on all long pages.
Cannot reproduce on gtk so probably Amiga only.
TagsNo tags attached.
Fixed in CI build #2029
Reported in CI build #2000
URL of problem pagehttp://sox.sourceforge.net/sox.html
Attached Files

-Relationships
related to 0002177closedMichael Drake Excessive stack usage 
+Relationships

-Notes
Chris Young

~0000420

Chris Young (developer)

I can reproduce this on http://git.netsurf-browser.org/netsurf.git/tree/amiga/gui.c (and other long source file pages elsewhere) without even doing the find operation using CI#2028.
NetSurf is getting stuck in a loop, with disk access, after the page loads. The last thing in the log is related to FavIcons, so it is probably getting trapped somewhere there is no logging.
Chris Young

~0000421

Chris Young (developer)

Further investigation points to the Grim Reaper being the cause of the disk access, so it appears NetSurf is actually crashing but for some reason GR is not displaying.

Ranger is pointing to NetSurf having run out of stack despite me recently doubling it to 256K.
Chris Young

~0000422

Chris Young (developer)

The amiga/gui.c page is using 461244 bytes of stack space.
Increasing the stack to 524288 (512K) fixes the find in page problem too.
Will set that as the minimum in the stack cookie later.
Chris Young

~0000423

Chris Young (developer)

Raised minimum stack to 512K in CI#2029.
Vincent Sanders

~0000719

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-07-06 11:36 Chris Young New Issue
2014-07-06 11:36 Chris Young Status new => assigned
2014-07-06 11:36 Chris Young Assigned To => Chris Young
2014-07-06 11:36 Chris Young Status assigned => confirmed
2014-07-25 23:10 Chris Young Note Added: 0000420
2014-07-25 23:17 Chris Young Note Added: 0000421
2014-07-25 23:24 Chris Young Note Added: 0000422
2014-07-25 23:30 Chris Young Fixed in CI build # => 2029
2014-07-25 23:30 Chris Young Note Added: 0000423
2014-07-25 23:30 Chris Young Status confirmed => resolved
2014-07-25 23:30 Chris Young Fixed in Version => 3.2
2014-07-25 23:30 Chris Young Resolution open => fixed
2014-07-30 10:12 Chris Young Relationship added related to 0002177
2015-03-10 11:12 Vincent Sanders Note Added: 0000719
2015-03-10 11:12 Vincent Sanders Status resolved => closed
+Issue History