2019-12-15 11:58 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002162NetSurfABENDpublic2015-03-10 11:10
ReporterChris Young 
Assigned ToVincent Sanders 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformAmigaOSAmigaOSOS Version4.1
Product Version3.2 
Target VersionFixed in Version3.2 
Summary0002162: Assert when closing NetSurf before homepage loads
DescriptionHaving a few Internet problems today, so ended up closing NetSurf before it had completed a DNS lookup for my homepage (Google). It ended in an assert which is in the attached log.
I've done this before without error so I think this has been introduced with the scheduled fetches.
Additional InformationIf I wait until the DNS timeout error I can close NetSurf without it asserting.

btw, everything else is working :)
TagsNo tags attached.
Fixed in CI build #1989
Reported in CI build #1986
URL of problem page
Attached Files
  • log file icon ns.log (1,330,138 bytes) 2014-07-01 21:37

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000399

Vincent Sanders (administrator)

This was caused because I erroneously believed that all fetches would be aborted during quit and that the refcount on the fetcher should be its initial value.

It appears that aborts on curl handles while resolving are asynchronous and do not complete until "later" the old code logged this outcome and forced the reference count, allowing the fetcher to be stopped anyhow.

I have re instigated the old behaviour with a comment explaining why its necessary.
Vincent Sanders

~0000709

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-07-01 21:37 Chris Young New Issue
2014-07-01 21:37 Chris Young Status new => assigned
2014-07-01 21:37 Chris Young Assigned To => Vincent Sanders
2014-07-01 21:37 Chris Young File Added: ns.log
2014-07-02 14:00 Vincent Sanders Fixed in CI build # => 1989
2014-07-02 14:00 Vincent Sanders Note Added: 0000399
2014-07-02 14:00 Vincent Sanders Status assigned => resolved
2014-07-02 14:00 Vincent Sanders Resolution open => fixed
2014-07-02 14:00 Vincent Sanders Fixed in Version => 3.2
2014-07-02 14:00 Vincent Sanders Description Updated View Revisions
2014-07-02 14:00 Vincent Sanders Additional Information Updated View Revisions
2015-03-10 11:10 Vincent Sanders Note Added: 0000709
2015-03-10 11:10 Vincent Sanders Status resolved => closed
+Issue History